Results 1 to 10 of 28

Threaded View

  1. #1
    New ROGer Array
    Join Date
    Nov 2019
    Reputation
    10
    Posts
    14

    GL503GE poor performance and random fps drops

    My laptop is ASUS Rog GL503GE with GTX 1050Ti and core i5 8300H cpu and 16 GB DDR4 2666 mhz ram. I purchased this laptop 1 year ago. Till 2 months back everything was running fine and GTX 1050ti was giving good fps on every games. Problem suddenly started when I updated to win 10 1903 . After that GPU is giving constant unplayable 20 fps in all games with lot of stuttering.
    I have done following troubleshooting to solve the problem but succeeded in nothing:
    1. reverted back to windows 10 1803 (clean install) + drivers installed as given by ASUS only
    2.reverted back to windows 10 1709 (clean install) + drivers installed as given by ASUS only
    3.Tried updating GPU drivers with latest one 441.34 and also tried beta ones (all were installed with DDU uninstallation procedure)
    4.Tried rolling back GPU drivers with OEM provided ones 399.24
    5. Updated win 10 to 1909 version ( clean install) + drivers installed as given by ASUS only
    6.Changed All setting in Nvidia control panel to best and as directed in all posts and also making GPU as default GPU processer
    7.The temperature of CPU and GPU are under normal conditions around 60 deg cel. No throttling observed anytime.
    8. I have tried all GPU drives from NVidia from 399.XX to 441. XX. Nothing solved FPS
    9. I installed MSI afterburner and no throttling observed anywhere
    10. From GPU-Z the GPU is observed to take full load at 100% but memory controller load is very less
    11. I have kept laptop at performance mode still no improvement, charger always connected
    12. No extra process is there in background too that may be eating the CPU or GPU.
    13.All settings like win 10 gaming DVR, game mode, xbox live etc were turned off. Still no improvement
    14.There is no dust too in fans and all are clean, running properly and fans giving proper response as per temperature elevation.
    15. All GPU benchmarks are coming very low with this laptop. (20 to 25 FPS everywhere)
    16. I reverted back to original setting as when Laptop first came. No improvement
    17. Tired updating bios to latest version. No improvement
    18. Tried downgrading to all past bios version . No improvement
    I am doing troubleshooting of all types since 2 months and very frustrated now and sad .
    I have observed one thing which should be noted :
    When I reset BIOS with CMOS battery removal method the GPU performs normal for 5 minutes only and FPS comes back to normal but after 5 minutes again 20 fps everywhere. The temperature of GPU and CPU remain around 60 degrees (no throttling) .The BIOS resetting methods brings back the GPU performance to normal for 4-5 minutes only and after that it becomes poor. I changed CMOS battery with new one but still problem remains same.
    Please help me someone. Guide me what should I do.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •