Results 1 to 8 of 8

Threaded View

  1. #1
    New ROGer Array
    Join Date
    Nov 2019
    Reputation
    10
    Posts
    3

    Rog Gladius II wireless RF broken firmware

    EDIT : I have fixed it, its kinda hacky but it saves the mouse from RMA. check my second post bellow.

    I have Rog Gladius II wireless mouse. Win10.

    So, today, when my mouse has recharged, I decided to plug it into computer to update. Well, that was the worst decision I have made today.
    Mouse firmware and ROG Armoury updated, but RF Dongle firmware failed. Sadly, I didn't screenshot that. Then I tried to connect mouse using RF wirelesss and there was no movement. Mouse works fine, but it wont connect to PC because dongle is ****ed up.

    So I read posts and tried to update to older firmware. I opened ROG Armoury, turned off mouse, pressed left mouse button, middle mouse button and right mouse button. I held them while I was connecting cable to PC. It started flashing blue light and started installing firmware. It was version 2.25.29. Sadly, it didnt work, I got this message:

    https://prnt.sc/qaxfzj

    I was sometimes able to see all firmware versions, it was showing this:

    https://prnt.sc/qaxfzg

    Lastly, if I tried to update, same thing happend, error -9 for the dongle(i assume) , but it doesnt say that it will update RF also

    https://prnt.sc/qaxfza

    I am not the only one to have this issue, :
    https://www.reddit.com/r/ASUS/commen...ouse_firmware/

    I hope this will help to fix the issue, otherwise I will have to RMA/ refund. If this is quality and pricey mouse I dont want to have this kind of problems, Shame, there is no QA? How could you bring a update that breaks things...
    This ASUS Softwere really sucks, I am really pissed off and dissapointed.
    Last edited by RoiIam; 01-19-2020 at 08:46 PM. Reason: update

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •