Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    ROG Enthusiast Array ultimazlitezjc PC Specs
    ultimazlitezjc PC Specs
    Laptop (Model)G750JX-DB71
    MotherboardMobile Intel HM87 Express
    ProcessorIntel Core i7-4700HQ
    Memory (part number)16GB DDR3L SDRAM
    Graphics Card #1Nvidia GeForce GTX 770M
    OS Windows 10 Home
    ultimazlitezjc's Avatar
    Join Date
    Nov 2012
    Reputation
    10
    Posts
    50

    Unhappy GL553V won't boot, no POST just lights

    Need help on my GL553V laptop please.

    Suddenly won't boot, just showing lights on its keyboard
    I don't know if its an error code, tried googling it but no avail.
    Have tried resitting memory on different slot also.

    https://youtu.be/3Dzrgxamhe0

    Anyone did have the same issue?
    Last edited by ultimazlitezjc; 12-15-2019 at 12:26 AM.

  2. #2
    New ROGer Array
    Join Date
    Nov 2019
    Reputation
    10
    Posts
    44

    Quote Originally Posted by ultimazlitezjc View Post
    Need help on my GL553V laptop please.

    Suddenly won't boot, just showing lights on its keyboard
    I don't know if its an error code, tried googling it but no avail.
    Have tried resitting memory on different slot also.

    https://youtu.be/3Dzrgxamhe0

    Anyone did have the same issue?
    sometimes the cable of the integrated monitor loses connection.
    so to isolate that out, please try with external monitor and see if it goes to operating system.

    you can also try to hold power button down for 30-45seconds then it uses failsafe values for the bios.

  3. #3
    ROG Guru: Orange Belt Array FULLMETALJACKET7's Avatar
    Join Date
    Mar 2018
    Reputation
    46
    Posts
    492

    Press FN+F8, see if anything happens.

  4. #4
    ROG Enthusiast Array ultimazlitezjc PC Specs
    ultimazlitezjc PC Specs
    Laptop (Model)G750JX-DB71
    MotherboardMobile Intel HM87 Express
    ProcessorIntel Core i7-4700HQ
    Memory (part number)16GB DDR3L SDRAM
    Graphics Card #1Nvidia GeForce GTX 770M
    OS Windows 10 Home
    ultimazlitezjc's Avatar
    Join Date
    Nov 2012
    Reputation
    10
    Posts
    50

    Quote Originally Posted by Tor_Spo View Post
    sometimes the cable of the integrated monitor loses connection.
    so to isolate that out, please try with external monitor and see if it goes to operating system.

    you can also try to hold power button down for 30-45seconds then it uses failsafe values for the bios.
    Hi, thank you for your reply.
    I've tried both of them but still won't boot and doesn't show anything on a second monitor using HDMI

    Quote Originally Posted by FULLMETALJACKET7 View Post
    Press FN+F8, see if anything happens.
    Hello, thank you.
    nothing happens on it also

    this video now shows another behavior when I left it plugged in https://youtu.be/Dpgs3W61WvM
    Last edited by ultimazlitezjc; 12-20-2019 at 07:19 AM.

  5. #5
    ROG Guru: Orange Belt Array FULLMETALJACKET7's Avatar
    Join Date
    Mar 2018
    Reputation
    46
    Posts
    492

    Unplug the battery and try again.

  6. #6
    ROG Enthusiast Array ultimazlitezjc PC Specs
    ultimazlitezjc PC Specs
    Laptop (Model)G750JX-DB71
    MotherboardMobile Intel HM87 Express
    ProcessorIntel Core i7-4700HQ
    Memory (part number)16GB DDR3L SDRAM
    Graphics Card #1Nvidia GeForce GTX 770M
    OS Windows 10 Home
    ultimazlitezjc's Avatar
    Join Date
    Nov 2012
    Reputation
    10
    Posts
    50

    Quote Originally Posted by FULLMETALJACKET7 View Post
    Unplug the battery and try again.
    Hi, Still the same issue even unplugging the battery inside.
    I am thinking that this might be a motherboard issue

    (also out of warranty)

  7. #7
    ROG Guru: Orange Belt Array FULLMETALJACKET7's Avatar
    Join Date
    Mar 2018
    Reputation
    46
    Posts
    492

    Quote Originally Posted by ultimazlitezjc View Post
    Hi, Still the same issue even unplugging the battery inside.
    I am thinking that this might be a motherboard issue

    (also out of warranty)
    Might be.
    Remove everything that is installed and try again. Leave nothing but the essential for it to power on. Only one ram stick and the battery should be enough.

  8. #8
    ROG Enthusiast Array ultimazlitezjc PC Specs
    ultimazlitezjc PC Specs
    Laptop (Model)G750JX-DB71
    MotherboardMobile Intel HM87 Express
    ProcessorIntel Core i7-4700HQ
    Memory (part number)16GB DDR3L SDRAM
    Graphics Card #1Nvidia GeForce GTX 770M
    OS Windows 10 Home
    ultimazlitezjc's Avatar
    Join Date
    Nov 2012
    Reputation
    10
    Posts
    50

    Quote Originally Posted by FULLMETALJACKET7 View Post
    Might be.
    Remove everything that is installed and try again. Leave nothing but the essential for it to power on. Only one ram stick and the battery should be enough.
    still the same issue

  9. #9
    New ROGer Array
    Join Date
    Nov 2019
    Reputation
    10
    Posts
    44

    Quote Originally Posted by ultimazlitezjc View Post
    still the same issue
    did you check is the lcd cable properly inserted in to its "slot"

  10. #10
    ROG Enthusiast Array ultimazlitezjc PC Specs
    ultimazlitezjc PC Specs
    Laptop (Model)G750JX-DB71
    MotherboardMobile Intel HM87 Express
    ProcessorIntel Core i7-4700HQ
    Memory (part number)16GB DDR3L SDRAM
    Graphics Card #1Nvidia GeForce GTX 770M
    OS Windows 10 Home
    ultimazlitezjc's Avatar
    Join Date
    Nov 2012
    Reputation
    10
    Posts
    50

    Quote Originally Posted by Tor_Spo View Post
    did you check is the lcd cable properly inserted in to its "slot"
    Yes, checked it and still the same.

    Is there any beep codes or lighting codes for this laptop model

Page 1 of 2 1 2 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •