Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Dec 2019

    Maximus XI Hero (Wifi) Display Issues with EVGA 980 GTX

    At initial build of this system I encountered some issues getting the GPU to work. Last week, it seemed to stop working after I let the machine go into hibernation/sleep mode. Some jiggery pokery in the BIOS and Windows 10 and eventually the GPU was detected and started working again. However, upon hibernation/sleep two evenings ago, my GPU display stopped working again and I had to use the on-board VGA, again. While in Windows with 'Microsoft Basic Display Adpater' (I tried to load Legacy drivers) showing in Device Manager, (and some Windows update that happened yesterday), Windows suddenly recognised the GPU and installed it! It was no longer 'Hidden' in device manager. So, yesterday, the GPU was working fine, again. I was gaming all day.

    Today, booting up the PC, with no changes, the GPU is not detected again. No display. Had to resort to VGA. I've had no luck getting the system to detect the GPU at boot. Things I've done:

    - Updated the BIOS
    - Cleared the CMOS, twice.
    - Loaded Optimised Defaults (a few times)
    - Enabled CSM in BIOS
    - Set primary display mode to PCIE in BIOS (from Auto)
    - Disabled Fast Boot
    - Put the card in a different PCI slot - no difference
    - Re-installed Windows
    - Disabled on-board graphics and connected monitor and TV only to the GPU (this seemed to work last week when I was having similar issues at initial build, but not this time)

    Everything else seems to be working just fine. I'm even able to play games through the VGA, but at lot lower settings. So I'm wondering, what problem does this motherboard have with my GTX 980?? GPU Post in BIOS doesn't recognise it at all but I think this only works for ASUS cards. How can I know if the motherboard is picking it up at all at the moment? The GPU is currently 'Hidden' in my Device Manager - does that mean it's connected?

    All recommendations welcome.


    Maximus XI Hero 390z (wifi)
    i9 9900K
    EVGA gtx980 Classified
    Corsair Vengenace RGB Pro 3200Mhz
    Samsung Pro 256GB SSD



  2. #2
    ROG Enthusiast Array howxcore PC Specs
    howxcore PC Specs
    MotherboardMaxims XI Hero- Wifi
    ProcessorCore I9 9900k 5.0 ghz
    Memory (part number)G.skill tridentz rgb 3600mhz 32gb
    Graphics Card #1msi rtx 2080ti trio x Gaming
    Sound CardSound Blaster X AE-5
    MonitorViewsonic XG270QG, BENQ PD3200U
    Storage #1970 evo m.2 1tb
    Storage #2Sandisk Ultra 3D SSD 2TB
    CPU Coolernzxt kraken x62
    Casenzxt 700i
    Power Supplyseasonic titanium 1000w
    Keyboard logitech g915 TKL
    Mouse logitech g502
    Headset Logitech G935 wireless
    Mouse Pad ICEMAT
    Headset/Speakers logitech z5500
    OS windows 10 pro 2004

    Join Date
    Nov 2018

    I would recommend checking with another dedicated gpu, could be that the gpu is dead and nothing to do with the motherboard.

  3. #3
    New ROGer Array
    Join Date
    Dec 2019

    Quote Originally Posted by howxcore View Post
    I would recommend checking with another dedicated gpu, could be that the gpu is dead and nothing to do with the motherboard.
    Here's hoping. Might just be time for a new GPU. I've tried all day to get this board to recognise this card. It's not even finding/using/sending a signal through it right from CMOS reset. It just seems so weird how it was fine all of yesterday but the moment it boots from cold it does this. I've got a little monitor connected to the card which usually displays the boot menu etc. before a signal is sent via the HDMI cable, and that's been showing nothing. The card is always 'hidden' in Device Manager. I've got a feeling my new installation of Windows 10 Pro (which has had driver compatibility issues with 980s for over a year now) is no longer recognising or simply ignoring the card over and above the on-board graphics. Recent updates may have exacerbated this, but it was fine yesterday. It could be a BIOS issue though as it doesn't seem to recognise it all anymore. Also, it always goes back to 'Auto' despite setting Graphics config to PCIE. I may try and install Windows again but it's getting to that point where the hassle might be more than it's worth.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts