Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Dec 2019
    Reputation
    10
    Posts
    1

    Asus Rog Strix X570 E-Gaming USB problems (with solution)

    Hi!

    I just wanted to share and describe everything in detail to everyone a USB problem (Keyboard and mouse) I had with my new Asus Rog Strix X570 E-gaming board from the very beginning at startup, and with a solution that at least worked for my part. As I red online on different forums and on this forum about similar USB problems, this "bug" on ASUS new and older boards seems to be a common problem, I guess. This will be a long read so please read through everything.

    It all started with that my keyboard (HyperX Fury) and my mouse (Logitech G502) didn't want to work at all from the very first startup when they were connected together at the same time, even to different USB ports. This board has 3.2 gen2 ports, nothing less. keyboard and mouse have 2.0.
    For example, if I only connected my kb first (without the mouse connected), and tried all the usb ports, it worked like it should. The same goes for the mouse, if only the mouse was connected it worked like it should, in all usb ports. So the ports are not bad at all. But for some reason the kb and mouse couldn't work together when they were connected at the same time, even in different ports. That ment the kb didnt turn on at all, or the mouse. It depended on which device I connected first. In the bios, all usb legacy support was enabled plus I also cleared cmos with taking out the mb battery, the problem was still there afterwards.
    To me, it seems like conflict or a bug with usb 2.0 devices connected to 3.2 gen2, with the whole usb controller.

    But here was the stranger part. For example, if only my kb was connected, I actually could connect a flashdrive (2.0) in any of the mb usb 3.2 ports, and it worked like a charm. The kb worked and the flashdrive worked. If I tried to connect my mouse in the same port where the flashdrive worked, the mouse didnt turn on. I think you get it now

    To make my post shorter, the solution for this usb conflict was to get a simple usb 2.0 hub and connect it to any of the mb usb ports. Then connect the kb and mouse into the hub and now the kb and mouse works together.
    BUT! When I ran adwcleaner (from malewarebytes), it found a file named "pup.legacy". At this time windows 10 was freshed installed and everything else. I did put this file in quarantine and suddenly my mouse stopped working.... I restarted my PC, mouse still not working. I opened adwcleaner, took that file from quarantine and the mouse started to work again like normal.

    To Asus, please look into your usb 3.2 gen2 XCHI controllers, especially maybe on the X570 platform. They,re not 100% functionell.
    I hope this helps maybe a little bit to someone with similar usb problems.

    Have a great day!

  2. #2
    ROG Junior Member Array
    Join Date
    Feb 2013
    Reputation
    10
    Posts
    2

    I know this is several months later but they don't work even with my powered USB hub except in the BIOS itself. It's after it posts that both turn off. It's insane. I've never seen this issue before. Google ain't my friend!!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •