Results 1 to 1 of 1
  1. #1
    New ROGer Array BeardedBaker PC Specs
    BeardedBaker PC Specs
    MotherboardASUS Zenith Extreme
    ProcessorAMD Threadripper 1950x
    Memory (part number)2x TDPGD416G3200HC14ADC01 32Gb Team Group T-Force Dark Pro 3200Mhz CL14
    Graphics Card #1EVGA 1080Ti SC2 Hybrid Edition
    MonitorSamsung Q60R 65" QLED TV 120Hz
    Storage #12x Samsung 970 Pro Nvme SSD 512Gb
    Storage #21x Samsung 970 Evo Nvme SSD 256Gb
    CPU CoolerAlphaCool Eisbaer 360
    CaseFractal Design Define R6 Blackout
    Power SupplyEVGA Supernova 1000W T2
    Keyboard Logitech TK820
    Mouse Razer Mamba Wireless
    Headset Logitech G930 Wireless Headset
    OS Windows 10 Pro
    Network RouterNetgear Nighthawk AC1750 w/ DD-WRT Firmware

    Join Date
    Aug 2018
    Reputation
    10
    Posts
    3

    A suggestion to everyone having problems with ASUS software. Try this!

    So I've spent the last few weeks getting my computer back in order after a rebuilt and reinstall of Windows. Prior to this I had been having trouble with the ASUS software, AI Suite had stopped working at some point, throwing asio.sys errors when trying to open. Not much rgb on my rig but aura and livedash would also either refuse to open or give error messages or even bsod the machine. So I decided I would clean install and start fresh. I did a reinstall, and then another, and another, and set system restore after system restore and yet I was still met with constant errors and crashes from the asus software. Primarily the COM, fan, and system drivers would cause the system to crash whenever I was running argus monitor for fan control (I had kinda sworn off ai suite a while back). Finally on my 4th reinstall and 53rd system restore I noticed that when my computer crashed it wasn't blue screening, just freezing and rebooting, and also not writing out any crash dumps.

    After doin a little research I was checking the crash handler registry entry when I notice another entry for "Guarded Host" and one of the keys was something like 'disablecrashdumps' I recalled that being a windows add-on package so I went to "add or remove packages" and sure enough I had the box checked for guarded host. I unchecked it and rebooted and would you believe that everything just worked now. All the software worked together, no crashes, no errors, everything running all at once, totally copacetic. So if you're like me and you want to try out stuff that you maybe aren't sure what it does, do yourself a favor and make sure you're got the guarded host add-on turned off before you start taking drastic measures.

    Tl:dr: In control panel>programs>add or remove windows features>uncheck "Guarded Host" if it is checked. It may solve all of your problems and make ASUS software tolerable again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •