Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Aug 2019
    Reputation
    10
    Posts
    1

    GX502 Need to Turn off Turbo to get Decent CPU temps?

    Right so,

    Bought this laptop not long ago. I checked the temps while playing and as it turns out, basically every single game gets my CPU to 95+ degrees. The first solution I found was to disable turbo though Throttlestop. While the temps are now much better, the performance does suffer. The next thing I tried was to put the laptop in Balanced power option, and set the Maximum Processor State to 99%. That also reduced the temps by a lot, but the performance is also quite worse. I tried doing the same thing using High Performance power option and setting it to 70% and the temp is still at 95 degrees.

    Undervolting doesn't seem to lower the temps enough, as I can only seem to reach -70 for stability

    Here are the benchmarks i got using UserBenchmark:

    Turbo mode activated with High Performance(99% max):
    https://www.userbenchmark.com/UserRun/23441453
    CPU package went up to 96 degrees

    Turbo mode activated with Balanced (99% max):
    https://www.userbenchmark.com/UserRun/23441541
    CPU package went up to 56 degrees

    Disabled Turbo mode with Balanced (99% max):
    https://www.userbenchmark.com/UserRun/23441656
    forgot to actually record temp

    Disabled Turbo mode with High Performance (99% max):
    https://www.userbenchmark.com/UserRun/23441816
    CPU package went up to 58 degrees

    So here's my question: Is there a way to significantly cool down my laptop without reducing performance too much?

    Thanks folks

  2. #2
    New ROGer Array
    Join Date
    Jan 2020
    Reputation
    10
    Posts
    3

    Try this

    I bet you’re locking core and cache offset together which is why you’re stuck at -70mV.*

    If you’re using XTU, go to Profiles, highlight Default, click Show Values, then hit Apply and exit (close the tray icon too).

    Uninstall XTU, restart, download Throttle Stop and set these settings:

    Check the box next to Speed Shift - EPP, highlight the default value (255 I think) and change it to 64, click Save.*

    Click FIVR, Core, Unlock Voltage, set Offset to -125, click Save Voltages Immediately and click Apply.

    Now click Cache, Unlock Voltage, set Offset to -50, make sure Save Immediately is checked, and click Apply then Okay.*

    Back on the main Throttle Stop screen click Save, then Turn On, and then minimize to tray. Make sure the icon in the tray is red (on) and run a quick bench like Firestrike or Cinebench multicore.

    If it doesn’t crash you can try to push the core offset higher, just know you have to reduce the cache offset almost equally to maintain stability in my experience on these ASUS laptops with the 9750H.

    With a -125mV/-50mV offset I saw my temps drop considerably on my GU502GV and G531GT. With a manual fan curve of 10-85% I haven’t come close to throttling in benchmarks, games, etc. where max temps never even reach the high 80s. Give it a try!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •