Results 1 to 1 of 1

Hybrid View

  1. #1
    New ROGer Array
    Join Date
    Jun 2019
    Reputation
    10
    Posts
    5

    Post Backlit Keyboard on 2019 Zephyrus G Issue

    To preface -- I had this issue and I have created a workaround for it. Skip to [Solution] to see.

    I've been having this weird specific issue with my Asus Zephyrus GU502.DU on bios 208 that has carried over between windows 10 installs and on two physically different SSDs. Sometimes after waking from sleep, hibernate, shutdown, or reboot, but most often sleep/hibernate, and most rarely cold boot, my backlit keyboard will not light up. I've installed all needed software for this to work, and verified that with ASUS support (I haven't gone to them with this specific issue yet). I get the on screen toast https://i.imgur.com/Eky7rK1.png but no cigar, the keyboard stays dark. I had had enough of it tonight and popped open ProcMon, and tracked the system calls being made whenever I tapped Fn+Up Arrow or Fn+Down Arrow. They led to Armoury Crate and some other services, as well as inter-process calls from them to services like 'Asus Optimization'.

    [Solution] As soon as I restarted 'Asus Optimization', my keyboard sprang back to life with light. I've set it up to restart the process if it fails under the Recovery tab for the service's properties. Hopefully that will work, otherwise I'll make a batch/ps script and post it here.

    Has anyone else had this issue on their laptops and come to a similar solution? I have been chasing it for almost two months, seems like it started around the time when I upgraded to the 208 Bios but that may just be a coincidence. Nobody else talks about this laptop much online, and everyone points to ATK being the issue - something AFAIK Armoury Crate uses internally but does not expose to the user in any meaningful way except for in its log files. There's no ATK-specific software to install, that's probably handled by the Armoury Crate helper service. And weirdly, I remember the keyboard backlight working even without any Asus software installed when I first installed windows 10 (drivers may have auto-installed from the internet, but I hadn't installed anything from their website.

    Hope this helps someone, or at least myself in the future!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •