Results 1 to 2 of 2
  1. #1
    ROG Guru: Orange Belt Array Puffnstuff's Avatar
    Join Date
    Dec 2014
    Reputation
    21
    Posts
    451

    ROG Crosshair VIII Hero WiFi Issues....I'm done with it

    I finally had enough of my new crosshair viii hero wifi and replaced it with a Gigabyte X570 Aorus Master last night. Asus refused to replace my new defective board with another new board even though I just purchased it from Newegg. I explained to them that it was defective out of the box and when I tried to generate a rma using their system it stated that my board was already under an rma and I'd just received it.

    I had to speak to a person who first stated they would cross ship me a replacement board, refurb not new, rather than give me a new board to replace my new defective board. Then they changed it to send in my defective board to their repair center and they will fix it. Enough is enough!

    The Gigabyte board is running correctly, albeit, I had to flash the bios before it would work with my 3900X. Asus has a more refined bios than the Gigabyte but at least my board works like its supposed to. I'm very disappointed with Asus right now and will not consider them in the future for any upgrades including routers. When I get the repaired board back I'm selling it and moving on.
    Asus ROG Crosshair VIII Hero Wi-Fi Gigabyte X570 Aorus Master, AMD 3900X, EVGA 360 aio, 32gb G.Skill Trident Z Neo, Samsung 970 Pro NVME 512gb, WD Black NVME 1 TB, Crucial MX500 2tb, Zotac GTX 1080 AMP!, EVGA Nu Audio, CM HAF 932

  2. #2
    ROG Junior Member Array
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    2

    Quote Originally Posted by Puffnstuff View Post
    I finally had enough of my new crosshair viii hero wifi and replaced it with a Gigabyte X570 Aorus Master last night. Asus refused to replace my new defective board with another new board even though I just purchased it from Newegg. I explained to them that it was defective out of the box and when I tried to generate a rma using their system it stated that my board was already under an rma and I'd just received it.

    I had to speak to a person who first stated they would cross ship me a replacement board, refurb not new, rather than give me a new board to replace my new defective board. Then they changed it to send in my defective board to their repair center and they will fix it. Enough is enough!

    The Gigabyte board is running correctly, albeit, I had to flash the bios before it would work with my 3900X. Asus has a more refined bios than the Gigabyte but at least my board works like its supposed to. I'm very disappointed with Asus right now and will not consider them in the future for any upgrades including routers. When I get the repaired board back I'm selling it and moving on.
    can you check the gigabyte master for me. does it have bios reset bug? when you set the fixed vcore and cpu multiplier, shutdown and turn it on.

    also, I have sleep problem with this master board too. it will auto wake up from sleep.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •