Results 1 to 1 of 1
  1. #1
    New ROGer Array
    Join Date
    Sep 2019
    Reputation
    10
    Posts
    1

    LightingService CPU usage increase triggered by Guild Wars 2

    For at least a few weeks I've noticed Aura's LightingService.exe (latest version installed by Armoury) going from it's usual 0.0-0.5% CPU usage to idling at 1-2% with spikes to 3%. Restarting the service does fix the problem, but it shows back up the instant I run Guild Wars 2's launcher (login/running game proper not needed). The CPU usage and some other related problems continue after the game is closed, until the service is restarted. GW2 has no RGB sync/interaction features that I'm aware of, and the game effects option is also disabled in Armoury.

    Aside from the CPU usage increase, LightingService.exe constantly starts constantly accessing AuraHueWrapper.dll as well as several registry keys. Sysinternals Process Monitor shows under normal usage, the Aura service will occasionally generate similar events at a rate of a few hundred over a 5 minute period. After GW2 has been launched, the service starts accessing this .dll and regkeys several thousand times every second. The ARGB strips connected to the header on my TUF Gaming X570 Plus Wifi also occasionally flicker in this bugged state. These additional issues also go away when Lighting Service is restarted.

    I don't know if Aura/LightingService or Guild Wars 2 are to blame for this problem. I've not found any other games or programs that trigger this behavior. But GW2 also shouldn't have any interaction with Aura, as it's not using RGB features.

    edit: I should also note that the lighting service can be restarted after GW2 is launched, and it will continue from there without issue. The trigger seems to only be the initial running of GW2's launcher.

    Below are the entries from LightingService.log that show up any time GW2 is launched.

    Code:
    2020-01-19 12:49:29,558 aurals_3.03.70 - [Watchdog] Timeout = 60 ms
    2020-01-19 12:49:29,558 aurals_3.03.70 - [AuAacDeviceEx] got Latency device : 0x11000, remain times(9)
    2020-01-19 12:49:29,558 aurals_3.03.70 - [Watchdog] Timeout = 61 ms
    2020-01-19 12:49:29,558 aurals_3.03.70 - [AuAacDeviceEx] got Latency device : 0x11000, remain times(8)
    2020-01-19 12:49:29,571 aurals_3.03.70 - [Watchdog] Timeout = 73 ms
    2020-01-19 12:49:29,571 aurals_3.03.70 - [AuAacDeviceEx] got Latency device : 0x11000, remain times(7)
    2020-01-19 12:49:29,571 aurals_3.03.70 - [Watchdog] Timeout = 73 ms
    2020-01-19 12:49:29,571 aurals_3.03.70 - [AuAacDeviceEx] got Latency device : 0x11000, remain times(6)
    2020-01-19 12:49:29,629 aurals_3.03.70 - [Watchdog] Timeout = 55 ms
    2020-01-19 12:49:29,629 aurals_3.03.70 - [AuAacDeviceEx] got Latency device : 0x11000, remain times(5)
    2020-01-19 12:49:29,629 aurals_3.03.70 - [Watchdog] Timeout = 55 ms
    2020-01-19 12:49:29,629 aurals_3.03.70 - [AuAacDeviceEx] got Latency device : 0x11000, remain times(4)
    2020-01-19 12:49:29,636 aurals_3.03.70 - [Watchdog] Timeout = 62 ms
    2020-01-19 12:49:29,636 aurals_3.03.70 - [AuAacDeviceEx] got Latency device : 0x11000, remain times(3)
    2020-01-19 12:49:29,636 aurals_3.03.70 - [Watchdog] Timeout = 62 ms
    2020-01-19 12:49:29,636 aurals_3.03.70 - [AuAacDeviceEx] got Latency device : 0x11000, remain times(2)
    2020-01-19 12:49:29,661 aurals_3.03.70 - [Watchdog] Timeout = 87 ms
    2020-01-19 12:49:29,661 aurals_3.03.70 - [AuAacDeviceEx] got Latency device : 0x11000, remain times(1)
    2020-01-19 12:49:29,661 aurals_3.03.70 - [Watchdog] Timeout = 87 ms
    2020-01-19 12:49:29,661 aurals_3.03.70 - [AuAacDeviceEx] got Latency device : 0x11000, remain times(0)
    2020-01-19 12:49:29,669 aurals_3.03.70 - [Watchdog] Timeout = 95 ms
    2020-01-19 12:49:29,669 aurals_3.03.70 - [AuAacDeviceEx] apply in async mode
    2020-01-19 12:49:29,669 aurals_3.03.70 - [Watchdog] Timeout = 95 ms
    2020-01-19 12:49:29,673 aurals_3.03.70 - [Watchdog] Timeout = 99 ms
    2020-01-19 12:49:29,673 aurals_3.03.70 - [Watchdog] Timeout = 99 ms
    2020-01-19 12:49:29,675 aurals_3.03.70 - [Watchdog] Timeout = 101 ms
    2020-01-19 12:49:29,677 aurals_3.03.70 - [Watchdog] Timeout = 103 ms
    2020-01-19 12:49:29,679 aurals_3.03.70 - [Watchdog] Timeout = 105 ms
    2020-01-19 12:49:29,681 aurals_3.03.70 - [Watchdog] Timeout = 107 ms
    2020-01-19 12:49:30,412 aurals_3.03.70 - [Watchdog] Timeout = 70 ms
    2020-01-19 12:49:30,412 aurals_3.03.70 - [AuAacDeviceEx] got Latency device : 0x10000, remain times(9)
    2020-01-19 12:49:30,412 aurals_3.03.70 - [Watchdog] Timeout = 70 ms
    2020-01-19 12:49:30,412 aurals_3.03.70 - [AuAacDeviceEx] got Latency device : 0x10000, remain times(8)
    2020-01-19 12:49:30,416 aurals_3.03.70 - [Watchdog] Timeout = 74 ms
    2020-01-19 12:49:30,416 aurals_3.03.70 - [AuAacDeviceEx] got Latency device : 0x10000, remain times(7)
    2020-01-19 12:49:30,416 aurals_3.03.70 - [Watchdog] Timeout = 74 ms
    2020-01-19 12:49:30,416 aurals_3.03.70 - [AuAacDeviceEx] got Latency device : 0x10000, remain times(6)
    2020-01-19 12:49:30,417 aurals_3.03.70 - [Watchdog] Timeout = 75 ms
    2020-01-19 12:49:30,417 aurals_3.03.70 - [AuAacDeviceEx] got Latency device : 0x10000, remain times(5)
    2020-01-19 12:49:30,419 aurals_3.03.70 - [Watchdog] Timeout = 77 ms
    2020-01-19 12:49:30,419 aurals_3.03.70 - [AuAacDeviceEx] got Latency device : 0x10000, remain times(4)
    2020-01-19 12:49:30,421 aurals_3.03.70 - [Watchdog] Timeout = 79 ms
    2020-01-19 12:49:30,421 aurals_3.03.70 - [AuAacDeviceEx] got Latency device : 0x10000, remain times(3)
    Last edited by mrstealth82; 01-19-2020 at 07:24 PM. Reason: adding info

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •