Results 1 to 9 of 9
  1. #1
    ROG Enthusiast Array
    Join Date
    Oct 2015
    Reputation
    10
    Posts
    35

    G703 GXR i9 9980HK G-Sync option not showing - solved

    hi Dears

    i got G703 with highest specs

    but i was not able to see the G-Sync option while opening Nvidia Control Panel , it is enabled by default ? and how to show this option

    Thanks

  2. #2
    ROG Guru: Green Belt Array
    Join Date
    Nov 2012
    Reputation
    75
    Posts
    740

    Have you downloaded and installed the latest NVIDIA driver and Control Panel?

    Driver: https://us.download.nvidia.com/Windo...l-dch-whql.exe

    GeForce Experience: https://us.download.nvidia.com/GFE/G...v3.20.2.34.exe

    Good Luck
    G752VSK, G75VW-3D, G51J, G1S
    Homebuilt Windows Server

  3. #3
    ROG Enthusiast Array
    Join Date
    Oct 2015
    Reputation
    10
    Posts
    35

    Hi


    Yes , both are downloaded already , but the option is not showing at all

  4. #4
    ROG Guru: Green Belt Array
    Join Date
    Nov 2012
    Reputation
    75
    Posts
    740

    Does your NVIDIA Control Panel show that you have a G-Sync Capable Display?
    Miniatura de Adjuntos Miniatura de Adjuntos NVIDIA Control Panel.png  

    G752VSK, G75VW-3D, G51J, G1S
    Homebuilt Windows Server

  5. #5
    Super Moderator Array
    Join Date
    Jan 2013
    Reputation
    100
    Posts
    2,226

    Unfortunately, not real familiar with the G703GXR yet, but according to the ASUS global (Please switch to your region if necessary through the icon in the bottom left-hand corner) download site and my information, looks like it also supports intel graphics since the Intel vga driver is posted for this model and as a result supports Optimus technology as well.

    https://www.asus.com/Laptops/ROG-G70...Desk_Download/

    My information also shows this model supports GPU switching, so something that may want to be looked into more.
    Didn't see a physical switch in the G703GXR user manual, so suggest checking Armoury Crate for this function to see if that can help with the G-sync issue.

  6. #6
    ROG Guru: Green Belt Array
    Join Date
    Nov 2012
    Reputation
    75
    Posts
    740

    Take a look at your Device Manager. Do you have both NVIDIA and Intel Display Adapters?

    Here's mine, I only have NVIDIA Display Adapter:
    Miniatura de Adjuntos Miniatura de Adjuntos Device Manager Display Driver.png  

    G752VSK, G75VW-3D, G51J, G1S
    Homebuilt Windows Server

  7. #7
    ROG Enthusiast Array
    Join Date
    Oct 2015
    Reputation
    10
    Posts
    35

    hi ,

    i tried most of solutions above but no results , and Finally i figured it out , what need to do is the only to open ( Aura ) , then going to home ( i letter on the left ) , then to activate( discrete graphics ) which is Optimus mode , it will ask to reboot and that's it

  8. #8
    New ROGer Array
    Join Date
    May 2020
    Reputation
    10
    Posts
    4

    No G-sync option

    Hi there! I recently got the ASUS ROG G703GXR 1080p i9-9980HK RTX 2080 version laptop. Could you please guide me as to how to enable G-SYNC on this laptop? I am unable to find it through the Nvidia control panel and anywhere else. My current Nvidia driver version is 445.87. I also noticed that there is no Intel UHD graphics on board. When I try to install the intel graphics drivers, it says "This computer does not meet the minimum requirements for installing the software." I checked the device manager and it shows only the NVIDIA GeForc8 RTX 2020 under display adapters. Please help. Thank you!
    Last edited by Angelfire_Snake89; 05-05-2020 at 05:59 AM.

  9. #9
    New ROGer Array
    Join Date
    May 2020
    Reputation
    10
    Posts
    4

    Quote Originally Posted by TurkROG View Post
    hi ,

    i tried most of solutions above but no results , and Finally i figured it out , what need to do is the only to open ( Aura ) , then going to home ( i letter on the left ) , then to activate( discrete graphics ) which is Optimus mode , it will ask to reboot and that's it
    Seriously, I wish you were more competent at explaining it in detail as to how you did it.

    Anyway, I have solved the issue too, and I will put it here in detail for everybody. Here goes:

    If your ASUS ROG Laptop has Optimus Technology, that is it using both an Intel based graphics chip (like UHD 630 in my laptop) and Nvidia graphics chip/card (like RTX 2080 in my laptop) and therefore has the ability to switch graphics depending on the application you're using (see https://www.geforce.com/hardware/tec...mus/technology), then you might be facing an issue in your Nvidia control panel where it shows no options regarding the enabling of G-Sync. In addition, the Nvidia control panel might only show the 3D settings tab and nothing else. Therefore, the following SIMPLE solution is for you, so that you can enable G-Sync on your laptop (REMEMBER: This is for those laptops whose display actually supports G-Sync).

    Just go to the Armoury Crate app and click on the tab on the left of the app that looks like an "i", which will take you to home or main screen of the app where it shows your CPU stats, GPU stats, Memory Storage, DEVICE CONFIGURATION, and the ability to switch between the different power modes like Windows®, Silent, Balanced, Turbo, and Manual. If you are unable to see Turbo and Manual, that is because your laptop is running on battery and have not plugged your laptop adapter to a wall power outlet.

    What is important to you right now is the DEVICE CONFIGURATION, under which it shows Win Key, ROG Key, GPU MODE, Touch Pad, Boot up Sound. If you cannot see the DEVICE CONFIGURATION tab or any of the other stats tabs, then that means they are hidden. In order to make them visible, go to the top right corner of the window where it shows two logos, the one on the left is 'Edit Tiles', go there and make the stat tabs visible.

    Now, the main thing we have all been waiting to do! See the GPU MODE key under the DEVICE CONFIGURATION tab, click on that! A small window will pop up saying "A system reboot is required to switch to Discrete Graphics mode and enable G-SYNC. Reboot now?" There you go! Do it! After reboot, go to the Nvidia control panel, and you will see that all the settings that were missing are now available, including the option to enable G-SYNC! Congratulations, problem solved! This is because you have disabled Optimus, as G-Sync is only linked to your Nvidia graphics (and of course the capability of your laptop display too).

    If you notice, we did not have any need to go to your system's Device Manager to disable your intel graphics, which others have suggested on other forums. That suggestion did nothing for me, instead it said your display is not attached to any graphics adapter. Laptops with Optimus technology behave differently and have different ways to fix an issue. To be honest, there is no issue with the laptop in the first place. It's just how it is. For the ASUS ROG laptop with Optimus technology, in order to switch to Discrete Graphics and enable G-SYNC, my suggestion is the way. Hope this clears up everything for everybody and solves your problem (although it is not a problem with your laptop but you just need to know how to change settings is all).
    Last edited by Angelfire_Snake89; 05-11-2020 at 06:15 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •