Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Jan 2020

    Question Cannot Access BIOS on ASUS ROG STRIX Z390E Gaming

    Hello All.
    This is the hardware:

    Asus ROG STRIX Z390E Gaming
    Intel i9-9900KF
    EVGA Hybrid RTX 2080 Super FTW3
    G.SKILL TridentZ RGB 32GB (2x16) F4-3600C16D-32GTZRC
    Samsung 860 Pro 256GB SSD

    (please let me know if any other info is needed.

    When I first got this mobo I put everything together and the system was able to boot into my OS (Windows 10) though it skipped the ASUS splash screen and BIOS cue. I tried multiple times to access the BIOS through restarts and through Windows advanced restarts but had no luck. Whenever I would hold down F2 or Delete or click these buttons repeatedly, the computer would freeze on startup and the BOOT LED debug light would remain lit until I turned the machine off. I called technical support and they advised me to remove CMOS battery and reinsert after a few minutes. After trying that, I was still unable to access BIOS but I was also unable to boot into my OS. Thinking I may have gottena dud with some kind of booting issue, I returned the mobo to the retailer and exchanged it for an identical one. This new mobo has demonstrated the same behavior with me unable to access BIOS no matter what method I try. I have tried to replace the ram to see if they might not be working correctly but the brand new ram I got from the store didn't seem to help at all. I haven't tried to remove the CMOS battery from this new board because of how it rendered my last one nearly useless. Any help would be much appreciated. I'm very much at a loss and would hate to have to return or RMA this one as well.

  2. #2
    ROG Guru: Yellow Belt Array Enderwiggin03 PC Specs
    Enderwiggin03 PC Specs
    MotherboardROG STRIX Z390-E Gaming
    ProcessorIntel Core i9 9900k @ 5.1Ghz on all 8 cores 1.36v
    Memory (part number)F4-4266C19D-16GTZR @ 4000Mhz CL16-17-17-35 1.45v
    Graphics Card #1EVGA RTX 2070 XC Ultra
    Sound CardCreative Sound Blaster X AE-5
    MonitorASUS VG248QE
    Storage #1Samsung 970 Evo 500GB m.2
    Storage #2Samsung 860 Evo 1TB SATA
    CPU CoolerEVGA CLC280 with 4x NF-A14 iPPC-3000 PWM (push/pull)fans
    CaseFractal Design R6
    Power SupplyEVGA G3 1000w
    Keyboard Logitech G513 Carbon
    Mouse Logitech G703
    Mouse Pad Logitech Poweplay
    OS Windows 10 Home x64

    Join Date
    Nov 2018

    Unplug the power supply from the back of the PC, hit the power button for about 10 seconds or so, plug it back in, and retry it. If that doesn't work, try CMOS reset.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts