Results 1 to 4 of 4

Threaded View

  1. #1
    New ROGer Array
    Join Date
    Jun 2019

    USB Type-C Doesn't Power Devices (Zephyrus GU502.DU)

    I've been having this weird issue with my Asus Zephyrus GU502.DU on bios 208 that has carried over between windows 10 installs and on two physically different SSDs. It had a type-c USB port that is (I think) managed and fed data by the Nvidia chip, or is at least connected in some way as it functions as a display output just fine. For devices with external power like drive docks and phones it connects and transfers data totally fine.

    What doesn't work is the usb-c ssd (definitely not thunderbolt, this is an AMD laptop and this drive works with typeA-C as well as type-c-c on my desktop) that doesn't even show up in device manager in windows let alone receive power and light its blue status light. I think it's something to do with either a sense pin that was never 100% soldered onto the board, or the PC doesn't know how to wake this port without external power to a connected device (super weird). Can anyone help me out here?

    Same deal with a usb-c keyboard that lights up when connected via type-a-c on the same laptop, but not type-c-c. The cable is a good cable that on another, externally powered data dock, pulls hundreds of megs per second read and write, and pulls hundreds of megs per second on this ssd on my desktop. I've also tried a long apple type-c to no avail. I haven't tried it in a while but back when first testing this I remember it charged a Samsung over type-c just fine so I don't think it's inadequate power delivery.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts