Results 1 to 4 of 4
  1. #1
    ROG Guru: White Belt Array AgentHunk's Avatar
    Join Date
    Jul 2018
    Reputation
    10
    Posts
    99

    Exclamation GL702ZC Black screen and no fan ,have power led.

    I was using the laptop yesterday playing total war rome 2 and everything was fine when I shutdown the laptop normally by going to start menu and selecting shutdown...

    10pm

    1 hour later it gives black screen and no fan,but I am getting power led....

    First thing I did was took it apart and cleaned dust and removed battery,then turned it on with ac power.
    Now it came to life for a minute and logged into the login screen.
    Then it had a pixel like diamond shape across my screen and then went dark...

    Then I took out ram and harddrive and same black screen but the fans were working....

    So fans work but black screen with ac power.

    I cleaned more with q-tips and air duster can the board carefully and put all the components back together and then I tried various methods to get into the bios and got nothing the fans werent working and the screen is black with power led....

    I have no job,money or way to RMA it......or send it in the mail.....

    Had laptop since july of 2018...bought it brand new from best buy....

    1 year and 7 months...of use ..took good care of it....

    Now what?

    I did update to the latest windows 10 build 1909 of january several days ago and I had been using the 306 bios since last year....
    Last edited by AgentHunk; 02-12-2020 at 01:04 AM.

  2. #2
    ROG Guru: White Belt Array AgentHunk's Avatar
    Join Date
    Jul 2018
    Reputation
    10
    Posts
    99

    Update

    I did a hdmi connect another monitor
    And got lines of grey white and pink colors in the display
    And it attempted to do a automatic repair and the showed blue screen asking me of i wanted to do a restore..

    I shutdown instead...


    Had some black screens and flashes if red images of squares and recrangles for a brief second before the blue screen.

  3. #3
    ROG Guru: White Belt Array AgentHunk's Avatar
    Join Date
    Jul 2018
    Reputation
    10
    Posts
    99

    I did another hdmi test and got a display to show up on other monitor and have seen attempts to fix repairs going on as well as the display showing 5 thick white static bars...



    I attempted automatic repair couple times and saw nothing change during restart for 25 minutes on other monitor was getting light up on monitor.



    But the screen was blank for that time...and couple power offs and power on before i waited 20 minutes....

  4. #4
    ROG Guru: White Belt Array AgentHunk's Avatar
    Join Date
    Jul 2018
    Reputation
    10
    Posts
    99

    I find it suspicious that updating to windows 10 1909 several days before my machine stopped working to make sense here....

    January 28, 2020—KB4532695 (OS Builds 18362.628 and 18363.628.

    Something about a master switch?
    This better not be what I think it is....

    What can I do?
    Last edited by AgentHunk; 02-21-2020 at 07:15 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •