Results 1 to 4 of 4
  1. #1
    ROG Enthusiast Array skyhopper01 PC Specs
    skyhopper01 PC Specs
    MotherboardMaximus XI Code
    ProcessorIntel I9-9900k @ 5.1ghz
    Memory (part number)GSKILL Trident Z RGB 32GB @ 4133mhz
    Graphics Card #1Asus ROG Matrix Platinum 2080ti
    MonitorAsus ROG Swift PG27UQ 4k 144HZ
    Storage #1Samsung 970 EVO 500GB
    Storage #2Samsung 860 EVO SSD 1TB
    CPU CoolerASUS ROG Ryujin 360mm
    CasePhanteks Enthoo Evolv TG
    Power SupplyAsus ROG Thor 1200p
    Keyboard Asus ROG Claymore
    Mouse Asus ROG Gladius II Origin
    Headset ASUS ROG Delta

    Join Date
    Mar 2018
    Reputation
    10
    Posts
    28

    ROG Theta 7.1 Volume Issue

    Hey Folks, So I recently purchased the Theta 7.1 headset to upgrade my ROG DELTA and I have discovered a weird issue when changing the output to 7.1 from stereo in ROG ARMORY. when using 7.1, all sounds become much quieter. I have to use the headset at 100 percent volume and it is not loud at all. Overall the General Volume of this headset does seem to be lower than the Delta. Does anyone have any insight on this issue or perhaps a soloution?

  2. #2
    New ROGer Array
    Join Date
    Feb 2020
    Reputation
    10
    Posts
    1

    Check if you haven't changed the 7.1volume control, like putting the bass all the way up. I did something like that and in fact, it pushes the audio of your system to the max, but only for the bass, making all the other sounds very low.

  3. #3
    ROG Junior Member Array
    Join Date
    Oct 2016
    Reputation
    10
    Posts
    1

    Exclamation

    Quote Originally Posted by skyhopper01 View Post
    Hey Folks, So I recently purchased the Theta 7.1 headset to upgrade my ROG DELTA and I have discovered a weird issue when changing the output to 7.1 from stereo in ROG ARMORY. when using 7.1, all sounds become much quieter. I have to use the headset at 100 percent volume and it is not loud at all. Overall the General Volume of this headset does seem to be lower than the Delta. Does anyone have any insight on this issue or perhaps a soloution?

    I have exactly the same problem, in stereo they sound relatively loud. But when I put 7.1 mode, it sounds very weak.
    In fact, I prefer to watch movies in stereo even though the source is 5.1, because nothing is heard.

    I come from a strix 7.1 (wired), and I thought that this was improving the hardware, but I think I was wrong.

  4. #4
    New ROGer Array
    Join Date
    Mar 2020
    Reputation
    10
    Posts
    3

    Premetto che anche io ho lo stesso problema per quanto riguarda la funzione 7.1, il suono è davvero basso anche al massimo. Qualcuno di voi ha aggiornato il firmware da Armoury 2? io si ed il suono è diminuito ulteriormente. Sono molto deluso da Asus!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •