Page 10 of 25 FirstFirst ... 8 9 10 11 12 20 ... LastLast
Results 91 to 100 of 247
  1. #91
    New ROGer Array
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    77

    Quote Originally Posted by vashish27 View Post
    Good to know,
    I hope you are using "silent" or "windows" mode in Armoury crate software. You can check corresponding settings in windows power options. If you choose "balanced" in Armoury, then it will generally apply high performance power settings.
    I recently upgraded to Windows 2004, got some other issues but not related to battery life
    HOw u install the armoury crate on GL504GM??

  2. #92
    New ROGer Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    14

    Hey everyone, i made a video that show the problem.
    Battery was at 51% before the crash at 0%

    https://youtu.be/8oPM4hnyW4Q

  3. #93
    New ROGer Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    14

    Click image for larger version. 

Name:	20200618_150115_HDR.jpg 
Views:	0 
Size:	245.9 KB 
ID:	85329


    Now it shows 54.4% battery wear, was at 8.4% before the crash.

  4. #94
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    33

    gl504 baterry problem

    Today I turned on the laptop, 71% battery, I entered the Browser and immediately the battery dropped to 0% , wear level 77% (normally 18% )...

  5. #95
    New ROGer Array vashish27 PC Specs
    vashish27 PC Specs
    Laptop (Model)ROG Strix SCAR II
    MotherboardGL504GW
    ProcessorIntel i7 8750H
    Graphics Card #1nvidia GeForce RTX 2070 mobile

    Join Date
    Aug 2019
    Reputation
    18
    Posts
    52

    Quote Originally Posted by silvergem View Post
    HOw u install the armoury crate on GL504GM??
    I am sure Armoury Crate came pre-installed on your pc, being GL504GM.
    a) When did you buy the laptop?
    b) Did you purge out bloatware when initially setting up your pc? Maybe you removed AC during that time.
    c) Check in ADD REMOVE programs if you have it?

    If (c) is yes
    c) type Armoury in the windows start search box and see if any suggestions come up?
    d) press ROG key (on top of F4 key near the volume buttons) and see if armoury crate opens.

    If (c) is no
    e) You need to install Armoury crate from Windows store.
    f) before installing AC from windows store, check that you have required services installed i.e. "Armoury crate service", "ROG live service" and "Refresh rate service". You can find latest versions of these services from ASUS product support page for your laptop.

    Hope it helps, let me know

  6. #96
    New ROGer Array vashish27 PC Specs
    vashish27 PC Specs
    Laptop (Model)ROG Strix SCAR II
    MotherboardGL504GW
    ProcessorIntel i7 8750H
    Graphics Card #1nvidia GeForce RTX 2070 mobile

    Join Date
    Aug 2019
    Reputation
    18
    Posts
    52

    thafunker, enrique and others,
    Sorry for asking so many questions but I am trying to find something common for all having this problem.

    a) Are you guys using ASUS Battery Health Charging on "Balanced" or "Maximum lifespan" mode and keeping the charger plugged in during normal usage?

    b) Are you calibrating the battery once every month or so?

  7. #97
    New ROGer Array
    Join Date
    Jun 2020
    Reputation
    10
    Posts
    8

    GL704GM Battery gone to 0%

    Hello Everybody... Just reading this post.
    I have the same issue, Battery drop to 0% for no reason.

    I have my GL704GM since December last year, I found about the problem about a month ago.

    I did a clean Win 10 Install, (since windows broke down by flickering screen), and installed all last Asus Drivers...
    I realized that the battery drop to 0% problem, started after installing My Asus Software from Microsoft Store

    By reading the post I'm trying updating the bios through device manager > firmware > system firmware
    It Updated to version GL704GM.309
    I will now make a Win 10 clean install and let you know how it goes.

    It's been about four months since this thread started; it would be Really Nice if ASUS could give a straight Answer.
    I'm also a fan of Asus, and love the Rog Strix Scar II, but they need to solve this issue.

  8. #98
    New ROGer Array
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    77

    Same battery wear which is 56%. Now this was gone after few days which accidentally charge up to 100%. This happened since the Myasus app became buggy lately and not opened on as startup program which i configured my laptop to charge only up to 60%.

    After that the Battery wear is now only 12-14%
    Click image for larger version. 

Name:	BatteryWearAsus.jpg 
Views:	0 
Size:	38.0 KB 
ID:	85398

  9. #99
    New ROGer Array
    Join Date
    Jan 2019
    Reputation
    10
    Posts
    77

    Quote Originally Posted by silvergem View Post
    Same battery wear which is 56%. Now this was gone after few days which accidentally charge up to 100%. This happened since the Myasus app became buggy lately and not opened on as startup program which i configured my laptop to charge only up to 60%.

    After that the Battery wear is now only 12-14%
    Click image for larger version. 

Name:	BatteryWearAsus.jpg 
Views:	0 
Size:	38.0 KB 
ID:	85398

    Issue was back again, when I Opened my laptop it went to 0%. then the wear level is 36%

  10. #100
    New ROGer Array vashish27 PC Specs
    vashish27 PC Specs
    Laptop (Model)ROG Strix SCAR II
    MotherboardGL504GW
    ProcessorIntel i7 8750H
    Graphics Card #1nvidia GeForce RTX 2070 mobile

    Join Date
    Aug 2019
    Reputation
    18
    Posts
    52

    Quote Originally Posted by mbushnaq00 View Post
    the issue came back today after a month it seems if I keep the laptop connected to the power for a long time, even though its configured in balanced mode, the issue reappears
    Ya maybe but being a gaming laptop, we are bound to keep it plugged in for longer periods, atleast a couple hours of gaming session even if its fully charged.
    Mind you it charges pretty fast, so even if I plug it in at around 50 %, it will charge upto 99-100% in next 30-40 minutes but still got to be connected to power.
    Anyway, thanks for the tip mate. And thumbs down for ASUS

Page 10 of 25 FirstFirst ... 8 9 10 11 12 20 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •