Page 13 of 27 FirstFirst ... 3 11 12 13 14 15 23 ... LastLast
Results 121 to 130 of 265
  1. #121
    ROG Enthusiast Array
    Join Date
    Oct 2012
    Reputation
    18
    Posts
    73

    BIOS 307 has been released for GL504GW.

    I will be testing to see if it fixes the issue, fingers crossed

    Edit: Nope still the same
    Last edited by mbushnaq00; 08-22-2020 at 12:52 PM.

  2. #122
    ROG Member Array
    Join Date
    Jun 2020
    Reputation
    10
    Posts
    8

    GL704GM Battery Drop to 0%

    Quote Originally Posted by mbushnaq00 View Post
    BIOS 307 has been released for GL504GW.

    I will be testing to see if it fixes the issue, fingers crossed

    Edit: Nope still the same

    I upgraded BIOS to 309 for the GL704GM also with my fingers crossed...
    Guess what... Still the same.

  3. #123
    ROG Enthusiast Array
    Join Date
    Oct 2012
    Reputation
    18
    Posts
    73

    Quote Originally Posted by Blake@ASUS View Post
    Dear all,
    We are working on this issue, we just made some progress.
    Thank you to some user's support on this.
    If there is anything new, I will let you know.
    Thank you.
    Dear Blake,
    Is there any update on the fix for this issue?

    I am available to test any fixes if possible.

  4. #124
    ROG Member Array
    Join Date
    Jun 2020
    Reputation
    10
    Posts
    8

    No News on Rog Strix Scar II - Battery Drop to 0%

    Quote Originally Posted by Blake@ASUS View Post
    Dear all,
    We are working on this issue, we just made some progress.
    Thank you to some user's support on this.
    If there is anything new, I will let you know.
    Thank you.
    Dear Blake@ASUS

    It's been a month since last post,
    Any news? please....

  5. #125
    ROG Enthusiast Array
    Join Date
    Oct 2012
    Reputation
    18
    Posts
    73

    Battery Replaced

    So I bit the bullet and went ahead to purchase a new battery from a trusted supplier.

    Even though my warranty is still valid, Asus has closed their main service center here and outsourced their support to 3rd party who seems to have very bad feedback from customers.

    Anyhow, battery has arrived today and seems to be legit with 0% wear Hopefully now this fixes the issue permanently, I will confirm back later after further validation.

    Btw, the buttom one is the old battery in the photo
    Miniatura de Adjuntos Miniatura de Adjuntos IMG_20200907_122620.jpg  

    IMG_20200907_123735.jpg  

    newbattery.png  

    Last edited by mbushnaq00; 09-07-2020 at 11:23 AM.

  6. #126
    ROG Enthusiast Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    34

    Baterry problem

    Quote Originally Posted by mbushnaq00 View Post
    So I bit the bullet and went ahead to purchase a new battery from a trusted supplier.

    Even though my warranty is still valid, Asus has closed their main service center here and outsourced their support to 3rd party who seems to have very bad feedback from customers.

    Anyhow, battery has arrived today and seems to be legit with 0% wear Hopefully now this fixes the issue permanently, I will confirm back later after further validation.

    Btw, the buttom one is the old battery in the photo
    Hi, I hope your problem is solved. At the moment, the problem has not reappeared on my laptop. battery wear ranges from 1 to 2%. I noticed that the power supply does not heat up so much and when it is charged the battery remains at 100% even after 2-3 days. Before, it was down 98%. The new battery has another series / overhaul than the factory one.

  7. #127
    ROG Enthusiast Array
    Join Date
    Oct 2012
    Reputation
    18
    Posts
    73

    Quote Originally Posted by enriquecs2005 View Post
    Hi, I hope your problem is solved. At the moment, the problem has not reappeared on my laptop. battery wear ranges from 1 to 2%. I noticed that the power supply does not heat up so much and when it is charged the battery remains at 100% even after 2-3 days. Before, it was down 98%. The new battery has another series / overhaul than the factory one.
    unfortunately, the new battery turned out to be defective. There is a sudden drop in charge from 30% to 7% and in 3 days I had 31% wear already. I will be asking for a replacement, but to be honest I lost hope in solving this issue.
    Last edited by mbushnaq00; 09-09-2020 at 11:21 AM.

  8. #128
    ROG Enthusiast Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    34

    Battery problem

    [QUOTE=mbushnaq00;814776]unfortunately, the new battery turned out to be defective. There is a sudden drop in charge from 30% to 7% and in 3 days I had 31% wear already. I will be asking for a replacement, but to be honest I lost hope in solving this issue.[/QUOTE

    ...Maybe is a faulty motherboard...replace the battery and if the problem ....is motherboard.

  9. #129
    ROG Enthusiast Array vashish27 PC Specs
    vashish27 PC Specs
    Laptop (Model)ROG Strix SCAR II
    MotherboardGL504GW
    ProcessorIntel i7 8750H
    Graphics Card #1nvidia GeForce RTX 2070 mobile

    Join Date
    Aug 2019
    Reputation
    18
    Posts
    52

    Quote Originally Posted by mbushnaq00 View Post
    unfortunately, the new battery turned out to be defective. There is a sudden drop in charge from 30% to 7% and in 3 days I had 31% wear already. I will be asking for a replacement, but to be honest I lost hope in solving this issue.
    I would say calibrate once and see the behavior, I am quite sure it will be better. Did you charge to full 100% initially, before putting it in normal use?
    Anyway whats the harm in playing a little before returning the battery if thats what you are going to do.

  10. #130
    ROG Enthusiast Array
    Join Date
    Oct 2012
    Reputation
    18
    Posts
    73

    Quote Originally Posted by vashish27 View Post
    I would say calibrate once and see the behavior, I am quite sure it will be better. Did you charge to full 100% initially, before putting it in normal use?
    Anyway whats the harm in playing a little before returning the battery if thats what you are going to do.
    yes it seems to be improving, wear level is reduced to 15% now, and the sudden discharge is no longer happening while in use.

    btw I initially charged it to 100% (it was 7% at first boot up) and left it for 2 more hours so I am not sure why this happened, hopefully, it gets better in the future.

Page 13 of 27 FirstFirst ... 3 11 12 13 14 15 23 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •