Page 28 of 28 FirstFirst ... 18 26 27 28
Results 271 to 273 of 273
  1. #271
    ROG Junior Member Array
    Join Date
    Feb 2014


    I just solved the issue. After updating "battery" position in "Drivers Booster" app. Laptop now works and discharges normal after unpluging ac adaper.

    Device Name: Microsoft Surface ACPI-Compliant Control Method Battery
    Device Class: Battery
    Device Vendor: Surface
    Current Version:, 23.05.2017
    Available Version: ,
    Hardware ID:

  2. #272
    New ROGer Array
    Join Date
    Jul 2022

    Motherboards issue

    Quote Originally Posted by Marioss View Post

    I have Asus Rog Strix Scar II GL504GM, the issue im running into is about the battery. When my battery is below 50% (more or less) and the laptop is off, when i power it on, and it is NOT with charger on, it starts normally and when i see the log in screen, i see the battery on the down right corner on the percentage that it was before i shut it down, and sudenly goes to 0 and shuts down. And when i power it on again (with charger this time), it is 0%.

    It is not draining when i shut it off, because this can be happen also if it is 50%, i shut it, and turn it on again after 15 minuts for example, so it is not drainage, also i see the percentage of the battery i had before i shuted, at least for 1 sec, so for a weird reason it remembers the % but then it goes to 0 and shuts it imediately. If it passes this second, and it not turned off, then its is ok, so sometimes it turns off, sometimes it waits for me to login as a normal boot procedure.

    I have All latest windows updates, i have latest bios update 310, i am really really carefull with the laptop, not stress it, not force it, not try any chemicals etc. I tried the tips i read on internet about fast boot, from computer or from bios or both, unistalled the Intel rapid storrage also that i read is not helping for that, also "delete" the battery from device manager so it installs its drivers again when it boots, still didnt help. The laptop is about 8 months new with extreme careful useage, and good battery charging.

    Except this, the battery working fine, and this is happening once every 2-3 boots, sometimes on every boot, this is never happend when my battery was 100% charged on the last shutdown. I dont know i feel it is software issue not hardware/battery issue because it happens only sometimes not always. So guys did anyone had this issue before? can you suggest something to try? Thank tou in advance.

    Is just some software/service from asus i think (seem's that on linux live distro it does not reproduce the problem), or in the worst case a motherboard fault in the battery readings. Or may be lines are messup.
    Last edited by kavencsteve; 07-24-2022 at 10:17 PM.

  3. #273
    New ROGer Array
    Join Date
    Oct 2020

    Quote Originally Posted by PTSONIC View Post
    FYI I had the very same problem and I bought a new battery from ASUS 7 months ago and the issue has not appeared again since then. Maybe consider buying a new battery? Mine costed around 70 euros.
    How have you bought battery directly from ASUS? On my local Asus web site it is written that they are not offering spare parts for their products :-|.
    I don't want to buy battery from third part companies, because the quality and condition of these batteries are unknown.

Page 28 of 28 FirstFirst ... 18 26 27 28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts