Page 4 of 4 FirstFirst ... 2 3 4
Results 31 to 33 of 33
  1. #31
    New ROGer Array
    Join Date
    Oct 2019
    Reputation
    10
    Posts
    17

    Quote Originally Posted by ncook06 View Post
    As you can probably tell by my previous comment, I was completely fed up and ready to make a decision. Since Amazon only offered 80% refund due to the timing, and Asus was going to require me to ship, I was between a rock and a hard place: continue flickering or pay for a resolution. I decided to reach out to Nvidia to see if they had beta drivers with PG43UQ support.

    In chatting with Nvidia support, the technician seemed to think that "Upcoming Driver" was wrong. He proceeded as if it were supported and there was a different driver or GPU issue. Everything was in order. Then he asked if I had tried a different DisplayPort. Turns out I had skipped the one of the most simple (although rare) failures.

    After a couple hours of testing, it seems that all of this because the DisplayPort 1 on my PG43UQ is flaky. It seems like DisplayPort 2 is fine. If this was indeed the problem, I'll RMA this with Asus when it's more convenient for me.
    Glad you have it working. I wasn't about to continue fiddling as my 100% refund was at it's time limit. I did try both Displayports on the display along with all 3 on my GPU. Nothing helped. So unless I got 2 dodgy Displayports the cause of mine is different. Does make me more confident trying for another. Rearranging room and decorating so may jusst wait till after that so one less thing to move around when new carpet is fitted.

    Good luck

  2. #32
    New ROGer Array
    Join Date
    Oct 2019
    Reputation
    10
    Posts
    17

    Trying again

    Got majority of room redecorated so decided to repurchase another PG43UQ. Hopefully I won't have any issues this time. On the plus side it's no less than it ewas when I purchased the faulty one so I'm saving almost £100

  3. #33
    New ROGer Array
    Join Date
    Oct 2019
    Reputation
    10
    Posts
    17

    Connected it up and spend 30 minutes or so trying to solve the issues....again! Turned HDR on in Windows display settings and loaded a game. Doesn't matter if I have a games HDR toggled on or not or even if a game supports HDR or not the moment I hit a volume key on keyboard I get a black screen for 6 seconds wityh a little flicker after around 3 seconds. Tried all 3 display ports on my GPU and both Display ports on the display anbd it's the same issue.

    Check for PG43UQ driver on Asus site and I have the latest version. Will see if there's a Nvidia driver available though I doubt it'll help even if there is. Calling the retailler in the morning. Glad it's a different retailler so I'm not possibly RMA'ing the same display to the same retailer.

    Suppose I should contact Asus tyech support again too!!!!

Page 4 of 4 FirstFirst ... 2 3 4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •