Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Feb 2020
    Reputation
    10
    Posts
    3

    Need help with game centre and fan

    So, there was an issue with my laptop, and my ex partner told me to remove all drives...remove windows and restart from the start...
    Did that and then something has gone wrong when reinstalling everything.
    Got everything I believe I need.
    (I am not techy with stuff with drives, so when helping please pretend you're talking to your grandma...)

    Before the game centre would show when you change the settings of the fan on the screen, when you would click the fan button. "Silent" "Balanced" and "Overboost"
    But now, it wont. The only thing game centre will allow me to do is have it on Auto fan...
    When I have my charger in, my CPU goes up to 70'c ....Sometimes 80...

    My laptop has recently came back from a warranety check.
    So I have no idea what to do...HELP? Please?

  2. #2
    ROG Guru: White Belt Array
    Join Date
    Jul 2013
    Reputation
    10
    Posts
    97

    take a look at the device manager. Are faulty devices displayed?
    A Yellow symbol with a call sign?
    Did you install all drivers from the homepage?
    Here is the last link for the gaming center ASUS ROG Gaming Center 2.6.1
    https://dlcdnets.asus.com/pub/ASUS/G...620.1582867510

    If you have reinstalled windows, be sure to install all windows updates
    best regards Tom
    Last edited by Tom Tromboni; 02-29-2020 at 05:50 AM.

  3. #3
    New ROGer Array
    Join Date
    Feb 2020
    Reputation
    10
    Posts
    3

    Nothing is working still

    Quote Originally Posted by Tom Tromboni View Post
    take a look at the device manager. Are faulty devices displayed?
    A Yellow symbol with a call sign?
    Did you install all drivers from the homepage?
    Here is the last link for the gaming center ASUS ROG Gaming Center 2.6.1
    https://dlcdnets.asus.com/pub/ASUS/G...620.1582867510

    If you have reinstalled windows, be sure to install all windows updates
    best regards Tom
    I've looked at the Device manger , and there's no fault signs given.
    Also, that link doesn't take me to what devices I need @_@
    Windows is up to date.
    I just don't understand why the symboals of what speed the fan is on, on the screen anymore, and how come the fan will only go to Auto.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •