Results 1 to 1 of 1

Hybrid View

  1. #1
    New ROGer Array
    Join Date
    Feb 2020
    Reputation
    10
    Posts
    1

    Battery Question. ASUS ROG GL503V

    Hello all.

    I have been working on this laptop GL503V and I am running t in to a battery issue.

    Let me start off with this.

    The laptop will be plugged in and will power up fine. Battery LED will be solid orange which I believe indicates charging.

    When Windows has loaded, it will say "56% available (plugged in)". As soon as I remove the AC adapter, it immediately shuts off. Windows will show to battery percentage and states that it is plugged in. The percentage will not increase or decrease.

    These are the steps I have taken to troubleshoot.

    1. Made sure Windows, all drivers and the BIOS is up to date.

    2. Uninstalled the battery drivers, shut down, disconnected battery and held power button down for 1 minute, connected battery and power cord.

    3. Tested to make sure the AC adapter is good. Took multi-meter to it and shows the 19.5v that it should.

    4. Took multi-meter to the battery and the pins on the MoBo to where the battery is connected and that shows 15.something V running as should.

    5. Cleaned connectors and pins on MoBo with electronic contact cleaner.

    6. Ordered a new battery, connected it and I get the same results except this one is on "34% available (plugged in)" and will not move and shuts off as soon as I remove the AC adapter.

    7. CMOS battery reset.

    8. Checked all Windows settings and nothing is unusual. I even did a factory reset on all power settings in the BIOS and in Windows.

    Any help on this matter would be greatly appreciated.

    Chris.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •