Results 1 to 5 of 5
  1. #1
    New ROGer Array
    Join Date
    Apr 2019
    Reputation
    10
    Posts
    3

    Exclamation [SOLVED] GL504GS Strange Keyboard issue

    I have 4 keys in my keyboard that do not work or work with a strange combination from time to time.

    my dxdiag:
    https://i.imgur.com/oHJwUkx.png

    my device manager:
    https://i.imgur.com/M9XQpbJ.png

    The keys A, Q, 1 and Tab don't work properly from time to time.
    I.E if I press any one of the above keys without holding down the shift key then no input. If I hold down the shift caps A is entered. If I want small A then I have to enable caps lock then press Shift + a. Similar issue for q & 1. The 1 on my num pad works correctly, only the key 1 above my q key is like this.

    I've tried to uninstall and update the device driver of my keyboard from the device manager. solves the problem for some time and then again the problem comes back after some time.

    Also, I've tried disabling and enabling the various accessibility functions, again works correctly for some time then it goes again like this.

    One more thing, I've tried reinstalling my os also but this also does not seem to solve my issue.
    Last edited by mnbk91; 03-16-2020 at 05:03 PM. Reason: issue resolved

  2. #2
    New ROGer Array
    Join Date
    Apr 2019
    Reputation
    10
    Posts
    3

    Quote Originally Posted by mnbk91 View Post
    I have 4 keys in my keyboard that do not work or work with a strange combination from time to time.

    my dxdiag:
    https://i.imgur.com/oHJwUkx.png

    my device manager:
    https://i.imgur.com/M9XQpbJ.png

    The keys A, Q, 1 and Tab don't work properly from time to time.
    I.E if I press any one of the above keys without holding down the shift key then no input. If I hold down the shift caps A is entered. If I want small A then I have to enable caps lock then press Shift + a. Similar issue for q & 1. The 1 on my num pad works correctly, only the key 1 above my q key is like this.

    I've tried to uninstall and update the device driver of my keyboard from the device manager. solves the problem for some time and then again the problem comes back after some time.

    Also, I've tried disabling and enabling the various accessibility functions, again works correctly for some time then it goes again like this.

    One more thing, I've tried reinstalling my os also but this also does not seem to solve my issue.


    any help on this pls, do i have to replace the whole keyboard for this issue or is this a software problem??

  3. #3
    ROG Guru: Brown Belt Array davemon50 PC Specs
    davemon50 PC Specs
    Laptop (Model)Asus G752VY-DH72 (17") and Asus G752VT-DH74 (17")
    MotherboardAsus ROG LGA2011-v3 Rampage V Edition 10, x99 EATX
    ProcessorIntel Core i7-6950X Extreme 10-core 25MB Cache 3.0 GHz
    Memory (part number)Corsair Vengeance LPX Red DDR4 DRAM 64GB-4x16 3333 (CMK64GX4M4B3333C16R)
    Graphics Card #1Sapphire Nitro Radeon R9 Fury 4GB HBM Backplate
    Graphics Card #2Sapphire Nitro Radeon R9 Fury 4GB HBM Backplate
    Sound CardAsus SupremeFX Hi-Fi Audio DAC
    Monitor(2) Dell UltraSharp U2515H 25-inch monitors
    Storage #1(4) SSD's - Samsung 960 & 970 1TB M.2, Intel 535 480G, Intel 510 250G
    Storage #2(3) HDD's - Western Digital Caviar Black 2TB 3.5-in SATA III 64MB Cache
    CPU CoolerCorsair Hydro Series H80
    CaseCorsair Obsidian Series 650D Black, ATX, Mid Tower
    Power SupplyCorsair Digital AXi-Series AX1200i (1200W) 80+ Platinum Rating
    Keyboard Logitech Wireless K360
    Mouse Logitech Wireless MX Anywhere 2
    Headset HyperX Cloud II
    OS Windows 10 Pro 64-Bit
    davemon50's Avatar
    Join Date
    Apr 2017
    Reputation
    48
    Posts
    1,126

    Sure is a weird issue, I've not heard of that before. But if I threw a guess at it, I would think you have a software conflict with something else that is re-assigning those keys. Do you have suspicion of anything that might do that to you? A hardware issue would be consistently the same IMO, and not change as you use the computer, so likely not that.
    Davemon50

  4. #4
    New ROGer Array
    Join Date
    Apr 2019
    Reputation
    10
    Posts
    3

    Quote Originally Posted by davemon50 View Post
    Sure is a weird issue, I've not heard of that before. But if I threw a guess at it, I would think you have a software conflict with something else that is re-assigning those keys. Do you have a suspicion of anything that might do that to you? A hardware issue would be consistently the same IMO, and not change as you use the computer, so likely not that.

    Yes, thanks for your help. it was a driver clash. After days and days of going through each driver one by one disabling and uninstalling many things i found that in device manager under human interface devices of all places changing a device from HID-Compliant system compliant system component to HID-Compliant device solved my problem.

    Apparently Scar II has many such driver clashes.

  5. #5
    New ROGer Array
    Join Date
    Mar 2019
    Reputation
    10
    Posts
    7

    I have same problem, can you please describe how you solved it? Thank you very much

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •