Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Mar 2020
    Reputation
    10
    Posts
    1

    ROG G20AJ No Boot troubleshooting help.

    Hello, im sorry if this is a bad format im new.

    We've had our ROG G20AJ desktop computer for a few years now, and we've had trouble with it in the past but things sorta, worked themselves out in the end and no trouble for about a year, year and a half until now.

    Basically :
    I turn it on, and the tower LED's are Red instead of flashing rainbow colors.
    It will not put a signal to the monitor (swapping the hdmi to another input shows the blue No Signal screen, while the main hdmi we always use shows a black screen)
    The LED's on the keyboard turn on when I turn it on so that works.
    The fans cycle for a few seconds before turning off
    When you press the power button, instead of having to press and hold it instantly shuts everything off.

    What i've done :
    Went in, moved the CMO'S cap to the other set of pins for a few seconds before returning it to its original pins
    left it unplugged for a few days
    I'm not computer smart but i dont think you can get to bios when theres no screen signal, but i did try the key combos.

    I dont know anything about the internals other than it has a 180w power brick, as it was secondhand from my brother who didn't know much more than I did.
    I've been told to upgrade the power supply, because the fans only run for a few seconds before turning off. But i dont know if that means just the power brick or the entire internal power supply box.

    For context, it worked just fine until one day i tried turning it on and this all happened. There was a power outage for about a minute inbetween uses, im not sure if that has something to do with it.

    Any help would be wonderful! If it is just a simple upgrade my power brick, a link to where you can purchase them would be lovely, im not sure how to tell the difference between laptop chargers of the same name and PC power bricks.

  2. #2
    Super Moderator Array
    Join Date
    Jan 2013
    Reputation
    100
    Posts
    2,225

    Welcome to the forums!

    If the power is staying on, check if you can toggle the caps lock and/or numlock lights on your keyboard if you have them which could indicate the system is getting to the bios at least, but don't expect your system can do that.

    Although there are different sizes of adapter tips used, the G20AJ does use similar adapters to some of the ASUS notebooks although the tip is often (but not always) straight rather than at a right-angle to make it easier to unplug which should not be a big deal for this discussion.

    Anyway, my information shows the G20AJ 180W adapter has a 5.5mm diameter tip which is similar to many of the older ASUS notebooks, so you can try to find an older notebook adapter with 5.5mm tip although you need to check the wattage too.
    ============
    ADAPTER 180W 19.5V 3P(5.5PIH)
    ============

    If you're in the U.S., it looks like the U.S. ASUS store is selling the 230W, 19.5V notebook adapter with 5.5 mm diameter tip that you can use as the 180W adapter if you have any interest in trying that even though it is a larger adapter than you need, but should still work fine.
    Otherwise, the 180W adapter with 5.5mm tip is not being sold by the U.S. ASUS store, so you may want to look for the 180W version elsewhere.

    https://store.asus.com/us/item/202001AM040000006/adapters-ASUS-Adapter-230W-19.5V-3P-%285.5PHI%29-with-Power-Cord
    ========================

    Not sure how much time, effort, and money you want to spend on this, but it's not for sure an AC adapter problem, so wondering if you have a shop you trust that you want to ask to check into it more, or maybe it's something you want to consider if another AC adapter does not help.

    Also, if you were not aware of it, many of the G20AJ units will use two AC adapters (the 230W adapter used by the G20AJ is not the same one mentioned above as the 180W adapter substitute, so please be aware of this ) rather than just one depending on the video card used, so wondering if you may have been missing an AC adapter as well if you want to check your video card specs, but if it was running fine with just one adapter and you want to get it back to how it was before, you don't need to worry about this part.
    Your graphics performance for games will probably suffer if you are missing one of the adapters you are supposed to be using though.
    It should not have much to do with the problem you are seeing right now and is only something to look into later if you can get the system working again.
    https://www.asus.com/us/support/FAQ/1010575
    Last edited by cl-Albert; 03-19-2020 at 06:03 PM.

  3. #3
    ROG Guru: Yellow Belt Array Welsh Whoopee's Avatar
    Join Date
    Jan 2016
    Reputation
    18
    Posts
    248

    welcome to the forums mate, it seems the only way to see if you have a issue is to buy a new 230w power brick, here is the link https://www.ebay.co.uk/itm/AC-Adapte...kAAOSwfJ5dXPTX
    [B]YOUTUBE CHANNEL @ https://bit.ly/2E1zKTE
    ASUS ROG G20 PLAYLIST @ https://bit.ly/32uD4Py

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •