Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    New ROGer Array
    Join Date
    Mar 2020
    Reputation
    10
    Posts
    8

    GL703VM Keyboard Stopped Working

    Hi all,
    I have a GL703VM. About a week ago the keyboard and back light stopped working. The only button that works is the power button. I am able to plug in a USB keyboard and it works just fine. Also, the power indicator light is on all the time now, even after I turn the laptop off. It didn't do that before. For an FYI, I am not well versed in computer software so I am hesitant to make some changes without knowing exactly what I'm doing. Here is what I have done (most of this is done through online research suggestions).

    What works on the laptop:
    1. Power Button
    2. USB Keyboard
    3. Mouse touchpad and buttons

    What I have tried:
    1. Update (or reinstall) drivers in device manager, but there are no keyboard options in the device manager for drivers. (Keyboard shows up with the USB keyboard plugged in and disappears when I unplug it).
    2. Downloaded Driver Booster hoping it would find the appropriate drivers for the keyboard. It didn't.
    3. Uninstalled ATK package and reinstalled it from ASUS driver website.
    4. Can't access the bios with the laptop keyboard, but can with the usb keyboard. (I could type with the usb keyboard and not the laptop keyboard in bios. I didn't make any changes in the bios. I believe the bios driver is up to date.)
    5. Tried the filter keys on/off in the settings. No luck.
    6. Called ASUS support. Since I couldn't access the bios with the laptop keyboard, they wanted me to do a factory reset on it. I asked if there are some drivers (or something) I could download to get the keyboard to work again. They said doing a factory reset would force the computer to find and download the appropriate drivers. I have not done this yet.

    I have backed up everything on my computer to an external hard drive, but would like to use the factory reset as a last resort option.

    Any extra help would be greatly appreciated!

  2. #2
    ROG Guru: Green Belt Array hexaae PC Specs
    hexaae PC Specs
    Laptop (Model)ASUS Gaming Laptop GL703GS
    MotherboardIntel HM370 Cannon Lake-H
    Processori7-8750H
    Memory (part number)32GB DDR4 @2666MHz (dual-channel)
    Graphics Card #1NVidia GTX 1070 8GB
    Monitor1080p 144Hz 17" G-Sync AUO B173HAN03.2
    Storage #11TB SSD Crucial MX300
    Storage #2NVMe Samsung PM916
    Mouse ROG Strix Carry Wireless-BT mouse
    Mouse Pad MouseRug collection
    Headset/Speakers Realtek HD (ALC295)
    OS Windows 10 PRO x64
    Accessory #1 XBox One Bluetooth gamepad
    Accessory #2 Hori Fighting Stick Mini
    Accessory #3 4K Blu-Ray UHD USB Archgon Star
    hexaae's Avatar
    Join Date
    Feb 2015
    Reputation
    27
    Posts
    634

    Interesteing... very similar: https://rog.asus.com/forum/showthrea...indows-updates
    Possibly a MAJOR bug in Windows Updates VS ASUS software (or BIOS)...
    GL703GS here...

  3. #3
    New ROGer Array
    Join Date
    Mar 2020
    Reputation
    10
    Posts
    8

    Yes it does seem like we have very similar issues. From some of my other research, others have had this same problem with other models too. I agree, I think it is a problem with Windows and ASUS software as well.

    Check this thread out. This one is a GL503GE, but it has exactly the same issues as mine. They were able to use a driver from ASUS listed as "Hotfix" which seems like fixed their issue. Except the keyboard stops working and they just reinstall the "Hotfix" again and everything works again.

    https://rog.asus.com/forum/showthrea...indows-FIX-100

    I tried the "Hotfix" for mine, but it didn't work. However, when you have to select the OS on ASUS's website, it isn't listed under Windows 10. I had to select "Other" under the OS drop down menu to show the "Hotfix". This other user's thread I attached here had the "Hotfix" actually listed under their OS. Maybe look to see if yours has the "Hotfix" listed on your OS and give that a try.

  4. #4
    ROG Guru: Green Belt Array hexaae PC Specs
    hexaae PC Specs
    Laptop (Model)ASUS Gaming Laptop GL703GS
    MotherboardIntel HM370 Cannon Lake-H
    Processori7-8750H
    Memory (part number)32GB DDR4 @2666MHz (dual-channel)
    Graphics Card #1NVidia GTX 1070 8GB
    Monitor1080p 144Hz 17" G-Sync AUO B173HAN03.2
    Storage #11TB SSD Crucial MX300
    Storage #2NVMe Samsung PM916
    Mouse ROG Strix Carry Wireless-BT mouse
    Mouse Pad MouseRug collection
    Headset/Speakers Realtek HD (ALC295)
    OS Windows 10 PRO x64
    Accessory #1 XBox One Bluetooth gamepad
    Accessory #2 Hori Fighting Stick Mini
    Accessory #3 4K Blu-Ray UHD USB Archgon Star
    hexaae's Avatar
    Join Date
    Feb 2015
    Reputation
    27
    Posts
    634

    I've found also ROG Aura Core Component 1.0.14 on https://ivanrf.com/en/latest-asus-dr...or-windows-10/ and tried to reinstall everything from scratch (Aura Core from MS Store, Aura Core Component 1.0.14, Aura Service* 3.03.38 hotfix). I've also tested without Aura Core Component as suggested on https://www.asus.com/support/FAQ/1036500/

    *Aura Service == LightingService

    Nothing changed for me, still problems...

    Also noticed BASIC EFFECTS like Music and Smart do not work anymore and keyboard leds stay off when selected (Customize 1, 2 do work as soon as I select any effect instead):


    BASIC EFFECTS:
    Music: led colors based on real-time audio play
    Smart: led colors based on CPU temp

    Gaming Laptop ASUS GL703GS (BIOS 310)
    CPU i7-8750H (iGPU unavailable)
    GTX 1070 8GB (non-Max-Q, 10DE 1BE1 - 1043 1011, GP104 A1, vbios 86.04.7c.00.24, Samsung VRAM)
    Windows 10 Pro 1909 (build 18363.720)
    Desktop res: 1080p (1920x1080)
    Screen: 144Hz + g-sync AUO B173HAN03.2 [AUO329D]
    Audio: Realtek HD Audio (ALC295 chipset)
    Hard disks: NVMe Samsung, SSD Crucial
    USB Blu-Ray 4K drive: Archgon Star MD-8102P-U3YC-UHDB (Pioneer BDR-UD04)
    Last edited by hexaae; 03-24-2020 at 06:03 PM.

  5. #5
    ROG Guru: Green Belt Array hexaae PC Specs
    hexaae PC Specs
    Laptop (Model)ASUS Gaming Laptop GL703GS
    MotherboardIntel HM370 Cannon Lake-H
    Processori7-8750H
    Memory (part number)32GB DDR4 @2666MHz (dual-channel)
    Graphics Card #1NVidia GTX 1070 8GB
    Monitor1080p 144Hz 17" G-Sync AUO B173HAN03.2
    Storage #11TB SSD Crucial MX300
    Storage #2NVMe Samsung PM916
    Mouse ROG Strix Carry Wireless-BT mouse
    Mouse Pad MouseRug collection
    Headset/Speakers Realtek HD (ALC295)
    OS Windows 10 PRO x64
    Accessory #1 XBox One Bluetooth gamepad
    Accessory #2 Hori Fighting Stick Mini
    Accessory #3 4K Blu-Ray UHD USB Archgon Star
    hexaae's Avatar
    Join Date
    Feb 2015
    Reputation
    27
    Posts
    634

    FIXED "BASIC EFFECTS" NOT WORKING ANYMORE

    Reinstalled old version. Just found that Aura Core from MS Store + Aura Core Component 1.0.14 + good old Aura Lighting Service 1.00.41 (from C:\eSupport\eDriver\Software\Win32App\ASUS\Aura Lighting Service\1.00.41\ directory after original out-of-the-box installation) restored at least BASIC EFFECTS: Music and Smart.
    Did not solve led (and keyboard) off issue after Shutdown or Hibernation (when this happens, to wake up led + keboard again I have to disconnect power cable and press power button to resume PC from battery).

    It's a Russian roulette with these crappy and untested ASUS software and Windows updates...
    Last edited by hexaae; 03-29-2020 at 09:35 AM.

  6. #6
    New ROGer Array
    Join Date
    Mar 2020
    Reputation
    10
    Posts
    8

    Yeah this is like Russian roulette. This makes me 2nd guess if I would get another ASUS product in the future. At least you are able to get your keyboard working again, it just sounds like a PITA to get it to work. I sure hope we are able to get some assistance in solving this issue. It seems that a lot of people (with other models) have other odd issues that they can't figure out either. It really does point to an issue with ASUS software working with Windows. It seems that some models have updates and fixes and others don't.

    I'll keep searching around. I may resort to doing a full factory reset. If I do, I'll let you know how that goes.

  7. #7
    ROG Guru: Green Belt Array hexaae PC Specs
    hexaae PC Specs
    Laptop (Model)ASUS Gaming Laptop GL703GS
    MotherboardIntel HM370 Cannon Lake-H
    Processori7-8750H
    Memory (part number)32GB DDR4 @2666MHz (dual-channel)
    Graphics Card #1NVidia GTX 1070 8GB
    Monitor1080p 144Hz 17" G-Sync AUO B173HAN03.2
    Storage #11TB SSD Crucial MX300
    Storage #2NVMe Samsung PM916
    Mouse ROG Strix Carry Wireless-BT mouse
    Mouse Pad MouseRug collection
    Headset/Speakers Realtek HD (ALC295)
    OS Windows 10 PRO x64
    Accessory #1 XBox One Bluetooth gamepad
    Accessory #2 Hori Fighting Stick Mini
    Accessory #3 4K Blu-Ray UHD USB Archgon Star
    hexaae's Avatar
    Join Date
    Feb 2015
    Reputation
    27
    Posts
    634

    Did you try to put it in Hibernation, unplug power cord and press Power button to resume (try more than once)? For me it temporarily re-enables leds+keyboard, 'till next hibernation/shutdown at least...
    Last edited by hexaae; 03-25-2020 at 09:08 AM.

  8. #8
    New ROGer Array
    Join Date
    Mar 2020
    Reputation
    10
    Posts
    8

    I did try that as well as other combinations. Nothing has worked.

    I tried looking under (C:\eSupport\eDriver\Software\Win32App\ASUS\Aura Lighting Service\1.00.41) like you had mentioned. I don't even have the "Win32App" in the software folder. I was hoping to find that and be able to get back volume and music controls.

  9. #9
    ROG Guru: Green Belt Array hexaae PC Specs
    hexaae PC Specs
    Laptop (Model)ASUS Gaming Laptop GL703GS
    MotherboardIntel HM370 Cannon Lake-H
    Processori7-8750H
    Memory (part number)32GB DDR4 @2666MHz (dual-channel)
    Graphics Card #1NVidia GTX 1070 8GB
    Monitor1080p 144Hz 17" G-Sync AUO B173HAN03.2
    Storage #11TB SSD Crucial MX300
    Storage #2NVMe Samsung PM916
    Mouse ROG Strix Carry Wireless-BT mouse
    Mouse Pad MouseRug collection
    Headset/Speakers Realtek HD (ALC295)
    OS Windows 10 PRO x64
    Accessory #1 XBox One Bluetooth gamepad
    Accessory #2 Hori Fighting Stick Mini
    Accessory #3 4K Blu-Ray UHD USB Archgon Star
    hexaae's Avatar
    Join Date
    Feb 2015
    Reputation
    27
    Posts
    634

    Strange... that dir is not deleted after pre-installed software deploy.
    You can find backup of restore DVDs with all files on https://www.asustreiber.de/downloads...ws-10?start=30

  10. #10
    New ROGer Array
    Join Date
    Mar 2020
    Reputation
    10
    Posts
    8

    Yeah it is strange. I'm not sure what is going on. Unfortunately, my laptop model isn't listed on that website. I did just see another user post up with very similar issues. Their first post dates back to October of 2018 and it still isn't solved. I didn't see this one before.

    https://rog.asus.com/forum/showthrea...rd-not-working
    Last edited by tmarszal; 03-26-2020 at 01:57 PM.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •