Page 2 of 2 FirstFirst 1 2
Results 11 to 17 of 17
  1. #11
    New ROGer Array charlie1337 PC Specs
    charlie1337 PC Specs
    Laptop (Model)STRIX GL502V
    MotherboardROG STRIX X570-E Gaming
    ProcessorRyzen 9 3900
    Graphics Card #1NVIDIA GeForce RTX 2070 Super
    MonitorG9
    CPU CoolerROG RYUJIN 360
    CaseBeQuiet
    Keyboard ROG Claymore
    Mouse ROG Spatha
    Headset A50

    Join Date
    Apr 2020
    Reputation
    10
    Posts
    1

    SPATHA problems and more

    Hi,

    i life with the pain of an full ROG build and fight with numerous problems with it.

    The newest issue is that the Spatha stops quit frequently for a second, all parts "Aura flash" and sometimes the plugin plug out sound comes up.
    I use it wired since the wireless version is not usable in FPS.
    Any ideas ?!


    Latest ways *recommended by ASUS Support* to to fix ROG stuff were,
    uninstalling Armoury Crate with a special uninstaller i got send by support and reinstalling with the Installer they send me too.

    Uninstall Tool: https://dlcdnets.asus.com/pub/ASUS/m...stall_Tool.zip
    Install Tool: https://dlcdnets.asus.com/pub/ASUS/m...nstallTool.zip

    This fixed most of the Aura Problems and
    the Problem with the Ryujin no fans responding problem.

    The problem with disappearing devices in the software took more work.
    first recommended try was uninstalling the software(Link) then removing the BIOS battery, boot and reinstall (link), didn't help.
    Only a full new windows install helped for this problem in the end.

    I really hope there are better solutions than a reinstall of windows to that SPATHA problem.
    Last edited by charlie1337; 06-18-2021 at 04:51 PM.

  2. #12
    New ROGer Array
    Join Date
    Dec 2021
    Reputation
    10
    Posts
    4

    Pairing issue latest armoury win 11

    Seems as though the issue is with armory crate maybe driver hard to say, but when I finally get it to pair and I mean finally as it does not exhibit the normal behavior for pairing I don't get a blinking blueish light just a flashing green one, sometimes it pairs first go sometime I have to reset the mouse and try several times and it finally works.

    I have just replaced the dock as I believed it might be an issue with the dock...same behavior, also replaced the battery , I do love this mouse the weight and hand feel, but it's just now a pain in the arse, when I switch it off or shutdown the computer same **** not paired again, when I launch armory it crashes the mouse and connection most of the time, sometimes randomly just surfing the net it drops connection nothing really adds up.

    Tried a friends Spatha as well same issue, so it has to be something OS or armory related.

    Any idea's anyone else got this issue are there any dedicated drivers for win 11 not in box from win blows or any firmware versions in the pipeline??

    Re-flashed firmware several times, never connected at the same time

    Dock V1.4
    Mouse V1.8

    Help please before my son scores a new wired mouse

    Cheers

  3. #13
    New ROGer Array
    Join Date
    Dec 2021
    Reputation
    14
    Posts
    13

    Asus Rog Spatha is one of the best wireless Mice currently available in the market. I am so surprised that you are facing this problem. I also purchased this mouse by researching and reading articles like https://10beasts.com/best-mmo-mouse/ and honestly, I am pretty happy with its performance. I suggest you to follow the below mentioned tips as it may help you in countering the problem.

    If you are experiencing problems with your Rog spatha wireless, there are a few things that you can do to try and fix the issue. Firstly, make sure that your device is properly connected to your computer. If it is not, connect it using the appropriate cable. Once it is connected, check to see if your computer recognizes the device by opening up Device Manager. If it does not appear in the list, you may need to install the appropriate driver for your operating system. You can find this driver on the manufacturer's website.

    If your device appears in Device Manager and is recognized by your computer, but you are still experiencing problems, try restarting your computer. If that does not work, try reinstalling the driver for your device. If that does not work either, it may be necessary to uninstall the driver for your device and install an official Windows driver.

    If your computer is connected to your device properly and you are certain that the issue is with the software on your computer, make sure you have installed all available updates on your computer by checking for them in Windows Update. Then restart your computer again. If there are no updates available, make sure that you are running the latest version of Windows 10 on your machine. If there are still no updates available after doing this, check if Microsoft has released any patches or bug fixes for Windows 10 recently.

  4. #14
    New ROGer Array
    Join Date
    Dec 2021
    Reputation
    10
    Posts
    4

    Basics have been done and more

    Quote Originally Posted by Albert90 View Post
    Asus Rog Spatha is one of the best wireless Mice currently available in the market. I am so surprised that you are facing this problem. I also purchased this mouse by researching and reading articles like https://10beasts.com/best-mmo-mouse/ and honestly, I am pretty happy with its performance. I suggest you to follow the below mentioned tips as it may help you in countering the problem.

    If you are experiencing problems with your Rog spatha wireless, there are a few things that you can do to try and fix the issue. Firstly, make sure that your device is properly connected to your computer. If it is not, connect it using the appropriate cable. Once it is connected, check to see if your computer recognizes the device by opening up Device Manager. If it does not appear in the list, you may need to install the appropriate driver for your operating system. You can find this driver on the manufacturer's website.

    If your device appears in Device Manager and is recognized by your computer, but you are still experiencing problems, try restarting your computer. If that does not work, try reinstalling the driver for your device. If that does not work either, it may be necessary to uninstall the driver for your device and install an official Windows driver.

    If your computer is connected to your device properly and you are certain that the issue is with the software on your computer, make sure you have installed all available updates on your computer by checking for them in Windows Update. Then restart your computer again. If there are no updates available, make sure that you are running the latest version of Windows 10 on your machine. If there are still no updates available after doing this, check if Microsoft has released any patches or bug fixes for Windows 10 recently.
    Honestly I would not be posting here if I had not done the basics, only thing available is in box driver for win 11 FW version for mouse and dock is still 1.8 and 1.4 has not been updated for some time now, I have reset the mouse and dumped its profiles and re-flashed firmware several times, there are no armory updates nor driver updates from ASUS, I purchased a new dock as I though it might be problematic same issue and behavior, used a friends Spatha as well same behavior, so its either armory / driver or possibly OS related, thing is the behavior is so erratic its hard to pin point what is causing the issue, after you get it paired it will stay paired for the entire day sometimes until reboot, other times it drops it's connection within minutes, when using in wired mode not an issue, as above battery has also been replaced.

  5. #15
    Moderator Array Nate152 PC Specs
    Nate152 PC Specs
    MotherboardROG Strix Z690-F Gaming WiFi
    Processori7-12700KF
    Memory (part number)Kingston Fury Beast 16GB (2x8GB) 6000MT/s (KF560C40B)
    Graphics Card #1ROG Strix 3090 Ti LC OC
    Sound CardROG SupremeFX
    MonitorHP ZR30w
    Storage #1Seagate Firecuda 530 1TB
    CPU CoolerEK Quantum Velocity2
    CaseThermaltake Tower 900
    Power SupplyEVGA Supernova 1600 T2
    Keyboard ROG Falchion NX / Strix Flare II
    Mouse ROG Chakram X/Chakram Core/Spatha X
    Headset ROG Delta S Animate
    Mouse Pad Steelseries Prism XL + ROG Scabbard II
    OS Windows 11 Home
    Accessory #1 2x Swiftech Maelstrom X300 D5 V2
    Accessory #2 2x Hardware Labs SR2 560 MP radiators
    Accessory #3 Lamptron FC-5 V3 fan controller
    Nate152's Avatar
    Join Date
    Feb 2013
    Reputation
    386
    Posts
    17,419

    Hi ghusko

    I'm using the ROG Spatha X with windows 11 and all is working well with Armoury Crate.

    Trying with a new dock and mouse would pretty much rule out a hardware issue, as you're leaning towards, it's probably time for a windows reinstall.

    Here is a screenshot of my Armoury Crate with the ROG Spatha X.

    Click the pic to make it bigger
    Click image for larger version. 

Name:	ac.png 
Views:	0 
Size:	614.5 KB 
ID:	91412

  6. #16
    New ROGer Array
    Join Date
    Dec 2021
    Reputation
    10
    Posts
    4

    I have the old Spatha not the X version, should really be no different but some of the device kit versions seem different

    Click image for larger version. 

Name:	Screenshot 2022-01-12 074408.jpg 
Views:	0 
Size:	92.6 KB 
ID:	91680

  7. #17
    New ROGer Array
    Join Date
    Dec 2021
    Reputation
    10
    Posts
    4

    reinstall Win11

    I have reinstalled windows 11 to no avail except to blown away downloads meter for the month still has same issue.

    Am I missing something obvious here when pairing do not get the flashing blue/white light just a flashing green one, is there a new process for pairing with latest firmware versions?

Page 2 of 2 FirstFirst 1 2

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •