Results 1 to 8 of 8
  1. #1
    New ROGer Array
    Join Date
    Jan 2020
    Reputation
    10
    Posts
    6

    Rog spatha wireless problem

    I bought the Rog spatha after hours trying to fix the aura because it need an old armory , now when i have it on wireless mode the mouse when i move it slowly it moves left instead of being accurate it happened when i restart my pc and before it solved by itself now it doesnt !
    Can anyone assist me ???? i cant find any info on how to fix it

  2. #2
    New ROGer Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    2

    1.80 firmware update

    same happend to me after i updated the frimwave and driver not it's completly useless in wireless mode. I 'm thinking about to change to razer and absolutly forgot ASUS....

  3. #3
    New ROGer Array
    Join Date
    Jan 2020
    Reputation
    10
    Posts
    6

    More problems

    the problem was the pairing ! now after 4 days that i thought i fixed the pairing ! when i put to charge under 90% on the dock it changes the color to pulsing green!
    it's crazy and messes up all my aura ! are we serious its on the most expensive mice in the market and the dont care to give us a good crate to easily work !
    ASUS WAKE UP !!!!!!
    I WANTED TO DO A FULL ASUS ROG PC BUILD BUT AFTER ALL THESE PROBLEMS NOOOOO WAY !!!!!!

  4. #4
    New ROGer Array
    Join Date
    Jan 2020
    Reputation
    10
    Posts
    6

    Firmware update fail

    So when i download the firmware 1.80 from the site and try to open it nothing happens.......... any solutions ????

  5. #5
    New ROGer Array HappyBerryTeddy's Avatar
    Join Date
    Apr 2020
    Reputation
    10
    Posts
    12

    Question

    Quote Originally Posted by nickDroy View Post
    So when i download the firmware 1.80 from the site and try to open it nothing happens.......... any solutions ????
    Check replies in your other threads please.

    Have to mention though that mine randomly stops the cursor moving (mouse on 1.80, receiver on 1.40). No massive deal since it happens only every once in a while. Have the impression it occurs less since I did the update, but no occurrence would be even better.
    Last edited by HappyBerryTeddy; 04-23-2020 at 03:02 PM. Reason: the problem frequency was ambiguous

  6. #6
    New ROGer Array TheMajekalBum PC Specs
    TheMajekalBum PC Specs
    MotherboardTUF Gaming x570-PLUS(WiFi)
    ProcessorAMD Ryzen 9 3900X
    Memory (part number)64GB TridentZ Neo 3600mhz
    Graphics Card #1ROG Strix RTX 2080 TI OC
    MonitorROG PG27UQ 27" 4k 144Hz
    Storage #1WD Black SN750 1TB NVME
    Storage #24TB Seagate BarraCuda 2.5" HDD
    CPU CoolerROG Ryou 240mm w/oled
    CaseThermaltake View 71
    Power SupplyROG Thor 1200 watt
    Keyboard ROG Claymore (CherryMX Red)
    Mouse ROG Spatha & Chakram
    Headset ROG Centurion
    Mouse Pad ROG Balteus QI & Sheath
    Headset/Speakers Bose Soundlink Mini
    OS Win 10 pro
    Network RouterROG Rapture
    Accessory #1 ROG Spotlight
    Accessory #2 ROG Magnus
    Accessory #3 Rog Terminal

    Join Date
    Mar 2020
    Reputation
    10
    Posts
    52

    You using it wired, wireless, or hybrid (receiver plugged in but also wired for charging)?

    I found my Spatha did weird stuff if plugged in hybrid in the computer. I know thats not a normal configuration but I figured Id throw this out there.

  7. #7
    New ROGer Array HappyBerryTeddy's Avatar
    Join Date
    Apr 2020
    Reputation
    10
    Posts
    12

    Post

    Quote Originally Posted by TheMajekalBum View Post
    You using it wired, wireless, or hybrid (receiver plugged in but also wired for charging)?

    I found my Spatha did weird stuff if plugged in hybrid in the computer. I know thats not a normal configuration but I figured Id throw this out there.
    Hey Majekal
    I use it exclusively wireless and charge it on the receiver. When it's on charge, I either use a razer mamba 2012 or a steam controller *both in wireless* as a mouse.
    Also run a cheap & loud & laggy but usable Rii keyboard with a wireless dongle. That one has no specialist software with it.

    I tried several things so far (not sure which of them since the firmware update, so will probably have to go through them again):
    • Unplug all the other dongles (mamba, steam, keyboard)
    • Close Razer synapse, close Armoury, and close both
    • Uninstall razer synapse


    I'll probably look into uninstalling Armoury and closing Steam too.

    At the moment I am fine with it since I don't play anything competitive/multiplayer but would be cool to figure it out.

  8. #8
    New ROGer Array HappyBerryTeddy's Avatar
    Join Date
    Apr 2020
    Reputation
    10
    Posts
    12

    Quote Originally Posted by HappyBerryTeddy View Post
    Hey Majekal
    I use it exclusively wireless and charge it on the receiver. When it's on charge, I either use a razer mamba 2012 or a steam controller *both in wireless* as a mouse.
    Also run a cheap & loud & laggy but usable Rii keyboard with a wireless dongle. That one has no specialist software with it.

    I tried several things so far (not sure which of them since the firmware update, so will probably have to go through them again):
    • Unplug all the other dongles (mamba, steam, keyboard)
    • Close Razer synapse, close Armoury, and close both
    • Uninstall razer synapse


    I'll probably look into uninstalling Armoury and closing Steam too.

    At the moment I am fine with it since I don't play anything competitive/multiplayer but would be cool to figure it out.
    Switched to another keyboard (Drevo BladeMaster 87) a few days ago and the mouse getting stuck issue seems to be occurring way less if at all. Maybe the Rii dongle was causing some interference.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •