Page 5 of 6 FirstFirst ... 3 4 5 6 LastLast
Results 41 to 50 of 53
  1. #41
    ROG Member Array
    Join Date
    Sep 2021
    Reputation
    10
    Posts
    10

    Quote Originally Posted by kcmcc View Post
    For anyone having random connection drops after updating to that 4.x.x.x firmware, I was able to roll back using the firmware updater from Marvells site using atlflashupdate -r

    Was able to pull from a backup and put me on 3.1.71

    since then I have had no drops, been a few weeks rendering nontsop, fingers crossed, I am running cat 7 10ft to a ubiquiti 10G managed switch. This is on R6EE. Hope this helps anyone, sorry if it's known knowledge but it's been driving me nuts. The rollback has fixed it, I am avoiding any further firmware updates for sake of stability. Before then I was using an intel x550 pcie card for connection which was rock solid, but had to remove it for other reasons. Wasn't looking forward to dealing with this problematic NIC until I did this rollback.
    do you still have a backup file? i lost mine. And will i keep my MAC while using your's ?

  2. #42
    ROG Enthusiast Array
    Join Date
    Jun 2013
    Reputation
    10
    Posts
    48

    Quote Originally Posted by Brafitter View Post
    do you still have a backup file? i lost mine. And will i keep my MAC while using your's ?
    I believe it was stored internally to the chip, I didn't reference any backup file, just ran that command and it found the restore version. Have you tried just running that command and seeing what happens? I can see if I can extract it, but not sure how off the top of my head. As far as MAC address, I am unsure, but pretty sure that will stay the same.

  3. #43
    ROG Member Array
    Join Date
    May 2017
    Reputation
    10
    Posts
    23

    I have both a R6E and a C100C network card and for some odd reason I cannot use the updater utility to update the card.

    I am on a R6E and I am noticing dropping when I first boot up the system I seem to be having a problem with the marvel updater utility

    Hi so I updated and the device manager is saying my marvel card is on version 3.1.6

    Marvel flash update is telling me 1.5.58 and that there is no available update.

    *update trying to get the drivers off station drivers says that it cannot be downloaded securely whatever that means.
    Last edited by Contact; 04-18-2022 at 08:20 PM.

  4. #44
    ROG Member Array
    Join Date
    Sep 2021
    Reputation
    10
    Posts
    10

    Quote Originally Posted by kcmcc View Post
    I believe it was stored internally to the chip, I didn't reference any backup file, just ran that command and it found the restore version. Have you tried just running that command and seeing what happens? I can see if I can extract it, but not sure how off the top of my head. As far as MAC address, I am unsure, but pretty sure that will stay the same.
    well, i managed to rollback from 4.2.29 back to 3.1.109. it was a pain but i have no idea if 3.1.109 is good for PCI\VEN_1D6A&DEV_07B1&SUBSYS_87571043&REV_02

    4.2.29 was not... wake from power off was not working

    Anyway thenk you for pointing out about that FW on chip. too bad it stores only one to revert to. Problem is that you have to revert using same FW update you currently have. I couldn't revert from 4.2.3x. strange considering backup was the same and on chip alredy.

    EDIT:
    it still says it's Marvell and not Aquantia 10GB E. any idea how to fix it?
    Last edited by Brafitter; 04-20-2022 at 11:09 PM.

  5. #45
    ROG Member Array
    Join Date
    May 2017
    Reputation
    10
    Posts
    23

    Quote Originally Posted by Brafitter View Post
    well, i managed to rollback from 4.2.29 back to 3.1.109. it was a pain but i have no idea if 3.1.109 is good for PCI\VEN_1D6A&DEV_07B1&SUBSYS_87571043&REV_02

    4.2.29 was not... wake from power off was not working

    Anyway thenk you for pointing out about that FW on chip. too bad it stores only one to revert to. Problem is that you have to revert using same FW update you currently have. I couldn't revert from 4.2.3x. strange considering backup was the same and on chip alredy.

    EDIT:
    it still says it's Marvell and not Aquantia 10GB E. any idea how to fix it?
    109 for the driver or the FW. I bet your talking about FW aren't you?

  6. #46
    ROG Member Array
    Join Date
    Sep 2021
    Reputation
    10
    Posts
    10

    Quote Originally Posted by Contact View Post
    109 for the driver or the FW. I bet your talking about FW aren't you?
    Yes, FW

  7. #47
    ROG Member Array
    Join Date
    May 2017
    Reputation
    10
    Posts
    23

    Quote Originally Posted by Brafitter View Post
    Yes, FW
    How did you revert the firmware?

  8. #48
    New ROGer Array
    Join Date
    Apr 2022
    Reputation
    10
    Posts
    1

    Not to rev an old thread, but where is this "diag" utility? I'm having an issue with my aquantia 107 and I want to try it.


    EDIT: I found it at Dell's website - https://www.dell.com/support/home/en...driverid=wj8f8

    Extract the EXE and there it is.
    Last edited by hwhitebread93; 05-03-2022 at 06:40 PM.

  9. #49
    ROG Member Array
    Join Date
    Sep 2021
    Reputation
    10
    Posts
    10

    Quote Originally Posted by Contact View Post
    How did you revert the firmware?
    Well, i did update from 3.1.109 to 4.2.29. And i found 3.1.109 at station drivers and used -r command. i i belive .xml had my HWID in it cus it worked.

    And since i was unable to update using marvel's 3.1.121a, i edited xml and it worked.

    lastest official drivers and FW now.

    no idea why FW from marvel didnt click but you can make it click.

  10. #50
    ROG Guru: Blue Belt Array restsugavan PC Specs
    restsugavan PC Specs
    MotherboardRAMPAGE VI EXTREME BIOS 3701 MOD
    ProcessorIntel Core i9 7980XE 2.60GHz
    Memory (part number)64GB GSKILL 3.2 GHz 16-16-18-36 2T
    Graphics Card #1ASUS ROG POSEIDON 1080Ti
    MonitorSAMSUNG ODESSEY G9 Firmware 1016.0
    Storage #1SAMSUNG 970 EVO PLUS 1TB x 3
    Storage #2WD 4TB External HDD
    CPU CoolerNZXT KRAKEN 62
    CaseCorsair Carbine 540
    Power SupplyCorsair AX1200i
    Keyboard Microsoft
    Mouse Microsoft
    Mouse Pad ASUS
    Headset/Speakers Sony
    OS Windows 11 Insider Preview 25247.1000
    Network RouterD-LINK
    restsugavan's Avatar
    Join Date
    Sep 2017
    Reputation
    167
    Posts
    815

    Lightbulb The best firmware for Aquantia AQC107n on R6E and older mobo was 3.1.121

    Due there are many AQC107-n SKUs NICs on the markets.

    The new revision (*** After Aquantia was acquired by Marvell Technology Inc.*** ) NIC ICs chip was different from the chip
    that provide by ASUS R6E and older model of motherboards that applied AQC107-n SKUs.

    New revision chip always coming
    with name " Marvell FastLinQ PCIe NICs cards " .

    For AQC107-n early revision chip. It was recommended by Marvell Technology Inc. to use 3.1.121 Firmware for the best.
    and The 3.1.16 driver already WHQL approved by Microsoft Corp. It was working very good with lastest Windows 11 Insider
    build as well.


    Click image for larger version. 

Name:	AQC107DRIVERA1.jpg 
Views:	26 
Size:	229.2 KB 
ID:	93193

    Marvell Aquatia AQC107n Firmware 3.1.121 working very well with 3.1.16 WHQL driver

    Click image for larger version. 

Name:	AQC107DRIVERA2.jpg 
Views:	24 
Size:	197.8 KB 
ID:	93194

    It was 100% compattible with Windows 11 lastest insider build.
    So consumer release RTM must be OK.

    There are products driver page link from Marvell Inc. below.
    Please choose the correct SKUs and OS platform driver from the link below


    Support | Driver Downloads | QLogic Fibre Channel HBAs and FastLinQ Ethernet adapters and controllers - Marvell

    Click image for larger version. 

Name:	AQC107DRIVERA3.jpg 
Views:	16 
Size:	115.8 KB 
ID:	93199
    Last edited by restsugavan; 05-26-2022 at 09:49 AM.
    Windows 11 22H2 Build 25247.1000 Core i9 7980XE 02006E05 MCU 2022-03-08 R6E 3701 MODDED BIOS TPM 2.0 Enabled VROC 7.8.0.1012 + RST 18.31.3.5434 ME FW 11.12.93.2323 DV 2229.3.2.0 64GB DDR4 3200 XMP POSEIDON 1080i GTX NVIDIA Driver 530.04 WHQL 3TB SAMSUNG 970 EVO PLUS OMS Driver 18.37.4.1007 WHQL i219 V EFI 0.2.02 Boot Agent 0.1.16 12.19.2.45 WHQL AQC 107N FW 3.1.121 AQC 3.1.7.0 WHQL Realtek HD 6.0.9430.1 WHQL SAMSUNG ODYSSEY G9 49 FIRMWARE 1016.0 VESA HDR 1000 DP

Page 5 of 6 FirstFirst ... 3 4 5 6 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •