Results 1 to 7 of 7
  1. #1
    New ROGer Array
    Join Date
    Jun 2019
    Reputation
    10
    Posts
    5

    Unhappy ROG DELTA Left RGB light doesn't work anymore. Any tips?

    Hi there!

    I recently bought a pair of DELTA headphones from amazon so i could use them with my Scar II and everything worked just fine for several months. A few days ago i realized that the left RGB is not working anymore (Right RGB light is still working). I thought that it was a software related issue at first but i tried changing the profile in Armoury, updating the BIOS (firmware) but nothing seems to work.

    I also have trouble trying to change the rgb presets, for example; I click on static color and there is still rainbow. Nothing changes. I'm not 100% sure but i recently updated something called: "AURA KIT / HAL / SDK Device firmware.

    PS: Connecting the headphones to my cellphone doesn't seem to fix the rgb issue

    Apart from that, everything works like a charm!. Any suggestions? i do think that the recent update messed up my headphones since they do not change RGB anymore, in the other hand, audio software and EQ still works. Is there a hard reset option anywhere?

    Sadly, i bought them second hand so i'm sure if the support will help me if a repair is needed.
    Last edited by Joakingdom; 04-08-2020 at 08:52 PM.

  2. #2
    New ROGer Array
    Join Date
    Mar 2020
    Reputation
    10
    Posts
    2

    Quote Originally Posted by Joakingdom View Post
    Hi there!

    I recently bought a pair of DELTA headphones from amazon so i could use them with my Scar II and everything worked just fine for several months. A few days ago i realized that the left RGB is not working anymore (Right RGB light is still working). I thought that it was a software related issue at first but i tried changing the profile in Armoury, updating the BIOS (firmware) but nothing seems to work.

    I also have trouble trying to change the rgb presets, for example; I click on static color and there is still rainbow. Nothing changes. I'm not 100% sure but i recently updated something called: "AURA KIT / HAL / SDK Device firmware.

    PS: Connecting the headphones to my cellphone doesn't seem to fix the rgb issue

    Apart from that, everything works like a charm!. Any suggestions? i do think that the recent update messed up my headphones since they do not change RGB anymore, in the other hand, audio software and EQ still works. Is there a hard reset option anywhere?

    Sadly, i bought them second hand so i'm sure if the support will help me if a repair is needed.
    I also have this problem. I bought the ROG Delta from the store a few month ago and today the left RGB light has stopped working and I could not set any light setting via Armoury Crate software.

  3. #3
    New ROGer Array
    Join Date
    Apr 2020
    Reputation
    10
    Posts
    1

    Quote Originally Posted by toonkl View Post
    I also have this problem. I bought the ROG Delta from the store a few month ago and today the left RGB light has stopped working and I could not set any light setting via Armoury Crate software.
    I have the exact same problem, my mb is an MSI B450 gaming plus and I updated the bios before the hedset stopped working. I hope the problem wil be fixed...

  4. #4
    New ROGer Array
    Join Date
    Jun 2019
    Reputation
    10
    Posts
    5

    About the issue

    UPDATE: Guys, i sent a ticket to support and they told me to check if my headset had the correct firmware. (It should be Version 0038 instead of 0039 which is BETA)

    https://www.asus.com/us/Headphones-H...HelpDesk_BIOS/

    Sadly, it didn't fix my problem at all.

    PS: Support also told me that they haven't received any customer reports about this specific issue so it would be a huge help if you guys can contact support as well and let them know. This can't be a coincidence.
    Last edited by Joakingdom; 04-24-2020 at 10:58 PM.

  5. #5
    New ROGer Array
    Join Date
    Dec 2018
    Reputation
    10
    Posts
    1

    :(

    me too

  6. #6
    New ROGer Array
    Join Date
    Dec 2018
    Reputation
    10
    Posts
    4

    Had the same thing with two headset :
    Bought the first one on August 2019 from Amazon, the left RGB died in November 2019. Had to return it since they do not "fix" headsets, they refunded me.
    Then I bought the second one from a local store in France on November 2019, the left RGB died todat August 1st 2020 (Irony lol).
    If anyone has any clue about how to fix the problem, let us know, cause I can't even send it back since I'm not in France anymore

  7. #7
    New ROGer Array
    Join Date
    Jul 2020
    Reputation
    10
    Posts
    1

    i have the same exact issue. Can't find any solution on internet and the asus support told me to contact the seller. Let me know if someone finds any solution.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •