Results 1 to 5 of 5

Threaded View

  1. #1
    New ROGer Array
    Join Date
    Apr 2020
    Reputation
    10
    Posts
    4

    A faulty Maximus VIII Formula motherboard?

    Hi!

    I have a problem with a Maximus VIII Formula motherboard. This motherboard has been lying around unused for a while, a few days ago I tried to see if I could use it to assemble a new computer. Please note that I am fairly confident in handling computer hardware but this is my first attempt at assembling a PC.

    So, after placing all the required parts in the case and connecting the cables I switched the power on. Nothing happens other than some red leds flashing at a slow rate. After reading some messages in various forums, I tried to isolate the board by taking it out of the case and detach all the cables other than power to verify if it is shorted. After I switch the power on I get the same slow flashing. I attach a short video so you can see what is going on.

    I can't find any information on this in the manual. My guess is that the motherboard is faulty and needs to be replaced but I would like to have a confirmation before I buy a new one.

    All help is welcome but please bear in mind that I am not an expert assembler.

    https://youtu.be/1k-kSrcUjKg

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •