Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1
    New ROGer Array omeggga's Avatar
    Join Date
    Jul 2018
    Reputation
    10
    Posts
    22

    ROG G752VS screen problem

    Hey.

    So... This problem is kicking my arse a bit. I'm not sure if my screen is somehow dented inward (unlikely since the laptop never moves) or if some LED decided it didn't want to work right anymore and wanted me to replace it. I'm sending a couple of pics.

    Click image for larger version. 

Name:	IMG_20200411_144743.jpg 
Views:	0 
Size:	312.4 KB 
ID:	84529
    Click image for larger version. 

Name:	IMG_20200411_142457~2.jpg 
Views:	0 
Size:	248.4 KB 
ID:	84530

    I tried connecting the laptop to an external monitor and the flaw isn't there, as well as shining my phones flashlight in the defective part in search of what may potentially be a bump when the screen is off to no avail.

    I'm almost convinced it's a malfunctioning LED, but if so, how do I fix it? And if not, what can it be?
    Last edited by omeggga; 04-11-2020 at 04:56 PM.

  2. #2
    ROG Guru: Green Belt Array
    Join Date
    Nov 2012
    Reputation
    75
    Posts
    742

    You either have a bad display or the display to motherboard cable connection needs to be reseated or the cable replaced.
    Last edited by jdfrench3; 04-11-2020 at 11:11 PM. Reason: Added info
    G752VSK, G75VW-3D, G51J, G1S
    Homebuilt Windows Server

  3. #3
    New ROGer Array omeggga's Avatar
    Join Date
    Jul 2018
    Reputation
    10
    Posts
    22

    Oh hey! Nice seeing you again!

    Anyway, how can I tell apart which of these possibilities is my issue?

  4. #4
    ROG NEWBIE Array mintys1's Avatar
    Join Date
    Feb 2014
    Reputation
    10
    Posts
    53

    Quote Originally Posted by omeggga View Post
    Oh hey! Nice seeing you again!

    Anyway, how can I tell apart which of these possibilities is my issue?
    Well we obviously cant tell you that...you at least need to check the display connector is seated correctly, then its a process of elimination.
    If you have no tech knowledge, take it to someone who does.
    Then watch and learn ...
    G750 -JHA -32GB -256GB SSD -512GB SAMSUNG 840 PRO SSD
    Windows 8.1...Home Ed.
    Latest Kit..Sep 2016
    G752-VY-32GB- 2 X 256GB SSD'S + 512GB SAMSUNG 840 PRO Windows 10 Home Edition.

  5. #5
    New ROGer Array omeggga's Avatar
    Join Date
    Jul 2018
    Reputation
    10
    Posts
    22

    UPDATE

    Okay so, I got a bit of a stripped screw problem on the chassis. Updates will come when I can solve this and open the laptop...

    Oh boy I'ma need a drill.

  6. #6
    New ROGer Array omeggga's Avatar
    Join Date
    Jul 2018
    Reputation
    10
    Posts
    22

    AAAND I'M BACK, ONLY 6 DAYS LATER AFTER MY LAST POST I TOOK OUT THAT SCREW. On a related note, anyone know where I can buy screws compatible with this laptop that are less likely to strip? Thanks in advance.

    Alright, recapping, I tried fiddling around with the bus but to no avail whatsoever. Both on the screen side and the motherboard side the bus seems... perfect, I guess. Maybe I could buy a new one and test that? Where would I buy such a cable though?
    Last edited by omeggga; 04-18-2020 at 01:27 PM. Reason: Clarification.

  7. #7
    ROG Guru: Green Belt Array
    Join Date
    Nov 2012
    Reputation
    75
    Posts
    742

    Take a look at the post, just below labeled "Help - G752VY-T7049T Replacement Screen Question" and PM Blake@ASUS for a solution to your display issue.

    Good Luck
    G752VSK, G75VW-3D, G51J, G1S
    Homebuilt Windows Server

  8. #8
    New ROGer Array omeggga's Avatar
    Join Date
    Jul 2018
    Reputation
    10
    Posts
    22

    Quote Originally Posted by jdfrench3 View Post
    Take a look at the post, just below labeled "Help - G752VY-T7049T Replacement Screen Question" and PM Blake@ASUS for a solution to your display issue.

    Good Luck
    Aaah. so we're sure it's not the bus then? alright. I wonder if I can replace this LCD with an LED though, that'd be sweet.

  9. #9
    ROG Guru: Green Belt Array
    Join Date
    Nov 2012
    Reputation
    75
    Posts
    742

    As I stated earlier:

    You either have a bad display or the display to motherboard cable connection needs to be reseated or the cable replaced.

    So you have contacted Blake@ASUS?

    Take your laptop to a local repair shop.

    Good Luck
    G752VSK, G75VW-3D, G51J, G1S
    Homebuilt Windows Server

  10. #10
    New ROGer Array omeggga's Avatar
    Join Date
    Jul 2018
    Reputation
    10
    Posts
    22

    Quote Originally Posted by jdfrench3 View Post
    As I stated earlier:

    You either have a bad display or the display to motherboard cable connection needs to be reseated or the cable replaced.

    So you have contacted Blake@ASUS?

    Take your laptop to a local repair shop.

    Good Luck
    I have contacted Blake@ASUS, they have yet to respond. Also the quarantine is still in effect so... can't go anywhere till may.

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •