Results 1 to 5 of 5
  1. #1
    ROG Enthusiast Array
    Join Date
    Jan 2015

    Prime X470-Pro: Need help setting up RAID 1 for 2 x HDD.

    I am building a new computer for a friend. He lost his last backup hard drive and want a RAID 1 backup drive for this rig.

    In BIOS, I only see nvme raid. But I don't get a raid menu on boot. I assumed I could do sata RAID there as well?

    Any tips or guides to help me set up RAID 1 for this rig?

  2. #2
    ROG Enthusiast Array
    Join Date
    Jan 2015

    One step closer:

    I download the manual for my MB. It says change from AHCI to RAID

    I reboot, still no raid menu.

    I read manual more. Under RAID section is says to download RAID Configuration Guide

    Guide says to disable CSM Compatibity then save & reset, then go back into BIOS to RaidXpert2 Configuration Utility.

    But I get no intro screen to press F2 and it boots straight to Windows.

    I hold Delete key upon reboot, but it still goes to Windows.

    Now, I am locked out of the BIOS!

  3. #3
    ROG Enthusiast Array
    Join Date
    Jan 2015

    Well, I cleared the CMOS, then reset the BIOS to defaults, then booted into windows and made sure the latest BIOS was installed. It was.

    I tried setting up RAID again, and same result. The splash screen for the BIOS doesn't appear and I can't get back in the BIOS.

    Any suggestions would be appreciated.

  4. #4
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Intel NUC laptop LAPQC71D
    MotherboardROG Crosshair VIII Dark Hero
    ProcessorAMD 5800X
    Memory (part number)32GB G.Skill Ripjaws V 3600
    Graphics Card #1ROG Strix RTX3090Ti
    Sound CardSound Blaster Z
    MonitorAORUS FV43U
    Storage #1Samsung 970 Pro 512GB
    CPU CoolerCustom loop
    CaseBeQuiet Dark Base Pro 900 V2
    Power SupplyCorsair HX1000
    Keyboard ROG Strix Flare II Animate
    Mouse ROG Chakram X
    Headset Steelseries Arctis Pro Wireless
    Mouse Pad ROG Scabbard
    Headset/Speakers Logitech z906 5.1
    Network RouterpfSense/OPNsense
    xeromist's Avatar
    Join Date
    Jul 2010

    Unfortunately I don't have the answer to your configuration questions but it's worth mentioning that RAID 1 is not a backup. If something disastrous happens to that PC both drives may be lost. And it's not unheard of to replace a failed drive only to have the intense array rebuild process kill another drive before the rebuild completes. So if your friend has important files they should be backed up periodically to separate hardware, preferably stored in another location.

    On a related topic, he should consider buying a spare drive now. That way if there ever is a failure he has a drive to use for rebuild. Waiting until there is a failure to look for a replacement, waiting for it to be shipped, etc. is not fun.
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

  5. #5
    ROG Enthusiast Array bluestang PC Specs
    bluestang PC Specs
    MotherboardASUS ROG Crosshair VII Hero
    ProcessorRyzen 3900X
    Memory (part number)F4-3600C15D-16GTZ (2 kits)
    Graphics Card #1MSI Armor OC 1660ti
    Graphics Card #2MSI Armor OC 1660ti
    MonitorASUS VZ249H
    Storage #1Samsung 970 EVO 250GB NVMe
    Storage #22x WD Red 10TB (RAID1)
    CPU CoolerFractal Design Celcius S36
    CasePhanteks Enthoo Luxe TG
    Power SupplySeaSonic Focus Plus Platinum 850W
    Keyboard Logitech MK-710 Combo
    OS Windows 10 Pro
    Network RouterASUS RT-N66U

    Join Date
    Oct 2019

    Posting in here for future reference. To get into the RAID Config Utility on boot you need to hit Ctrl-R for it.

    Also, mt boot drive was an SSD that originally had Win 7 Pro on it and then was upgraded to Win 10 Pro. It was then cloned to an NVMe SSD drive so I could get rid of my aging SATA SSD. I CAN NOT disable "CSM Compatibility" in BIOS to see the RAID Config in BIOS or to use the Ctrl-R utility. If I disable CSM I can't boot into Windows since it wasn't set up as UEFI as it was technically originally done with a Win 7 setup (see above). So I have to leave CSM enable to bee able to boot into Win 10.

    However, you can still setup a RAID inside Windows using the RaidXpert2 software package from AMD website. This contains the drivers and Utility to run under Windows. I had to set mine up that way in Windows and even though it was a pain in the arse it worked fine to created a RAID1 on 2x10TB WD Reds. I had the 1 already in the system and wanted to add the other to mirror for the RAID1. It did not want or let me "Transform" into RAID1 from a single drive no matter what I tried. I had to backup the drive to an external, then delete any Array(s) it said I had and then create a new Array for the RAID1. Then restore to that new Array...took 3-4 days to do.

    I will say that Intel's onboard RAID is so much easier to use. All I would have had to do was take the new drive and install in the system. Go into the Utility and tell it to create/transform into a RAID1 and in would have done it in the background. AMD fails at the software RAID game for sure...making more complicated than it has to be.

    Anyways I figured this could help others out if they find it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts