Results 1 to 4 of 4
  1. #1
    New ROGer Array
    Join Date
    Sep 2019
    Reputation
    10
    Posts
    6

    GL504GW automatically powers down

    Hi, just got this gaming laptop for my video editing needs last August 2019. I have it plugged to AC (with maximum life for battery option). I haven't used it for a week and just yesterday when I opened up the laptop, it automatically turned on without me pressing on the power button (power LED lighted up), it displayed ROG logo and then automatically shutoff. Looked at the power LED and no light. so waited for a few minutes and with the laptop open, I tried to press on the power button but nothing. closed the lid and then opened it up again and LED light turned white, displayed the ROG log and shutdown again. So last night, removed the charger and this morning, without the charger, opened the lid, LED light on, ROG banner displayed, turned off again. I tested the AC charger and it outputs 19.55V so the charger is working. Don't know what is going on.

    Any assistance would be much appreciated. Thank you.

  2. #2
    New ROGer Array PowerPein PC Specs
    PowerPein PC Specs
    Laptop (Model)GL504GS
    MotherboardASUS Rog Scar II
    Processori7-8750H
    Memory (part number)Kingstone hyperx 2X16 GB
    Graphics Card #1Geforce GTX 1070
    Sound CardRealtek/ USB Roccet Juke
    Monitor1080P 144 Hz
    Storage #1Toshiba SSD PCIe
    Storage #2Toshiba SATA III 2 TB
    Power Supplyoriginal
    Keyboard USB ASUS strix tactic pro
    Mouse TRUST gaming mouse
    Headset Sonic G910 7.1 vibration
    Headset/Speakers Genius GX 3000 2.1
    OS Win 10 Enterpise
    Network RouterASUS RT AC 1200 G
    PowerPein's Avatar
    Join Date
    Jan 2020
    Reputation
    10
    Posts
    31

    Quote Originally Posted by georgiejr View Post
    Hi, just got this gaming laptop for my video editing needs last August 2019. I have it plugged to AC (with maximum life for battery option). I haven't used it for a week and just yesterday when I opened up the laptop, it automatically turned on without me pressing on the power button (power LED lighted up), it displayed ROG logo and then automatically shutoff. Looked at the power LED and no light. so waited for a few minutes and with the laptop open, I tried to press on the power button but nothing. closed the lid and then opened it up again and LED light turned white, displayed the ROG log and shutdown again. So last night, removed the charger and this morning, without the charger, opened the lid, LED light on, ROG banner displayed, turned off again. I tested the AC charger and it outputs 19.55V so the charger is working. Don't know what is going on.

    Any assistance would be much appreciated. Thank you.
    Hi,

    Probe: connect AC plug, and push 5 sec power button. Probe starting, and fast pressed F2 key and opening BIOS. Can used bios, its good. Well operating system not working.

  3. #3
    New ROGer Array
    Join Date
    Sep 2019
    Reputation
    10
    Posts
    6

    Hi PowePein.

    Unplugged the power cord. Opened the lid, powered and ater 2 secs, shut down. Plugged in AC cord, held down power button about 5 secs and just dead to the water.

    I can't bring it to the service center close by, but we are on lock down so can't go out and besides the service center might be closed.

    Thank you for the tip.

  4. #4
    Moderator Array
    Join Date
    Feb 2019
    Reputation
    13
    Posts
    471

    Hello geogiejr,
    Please kindly send your device to service center .
    Thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •