Results 1 to 2 of 2
  1. #1
    ROG Enthusiast Array joppiano PC Specs
    joppiano PC Specs
    MotherboardASUS ROG Strix Z390-F
    Processori7-9700K @ 5.0GHz
    Memory (part number)Corsair Vengeance RGB @ 3000MHz 16GB (2x8GB)
    Graphics Card #1ASUS ROG Strix 2070
    MonitorASUS ROG Strix XG258Q
    Storage #1Samsung 970 EVO Plus 500GB - M.2 Card
    Storage #2Toshiba P300 3.5´´ 2TB
    CPU CoolerNZXT Kraken X72
    CaseNZXT H700i Window Black
    Power SupplyCorsair RM750x

    Join Date
    Apr 2019
    Reputation
    10
    Posts
    29

    Power Limit Exceeded - But how?

    Hello.

    I recently ran into some instability issues with my overclock and system in general.
    I wanted to start from scratch, so I decided to update my BIOS before, since there was 4 newer versions for my board.

    I succesfully updated BIOS, and wanted to run some Cinebench R15 tests with only XMP enabled, to see if everything was fine.
    I noticed the first couple of runs, was just fine - running at 4.6GHz on all cores as it should. But after 2-3 runs, I suddenly noticed my core clock throttling down to 4.2/4.3GHz.
    I noticed in HWinfo that it says "Power Limit Exceeded" for all 8 cores was "Yes".

    https://gyazo.com/060f6aaf5deb2fa2517b9c919f76e685

    I know that I can probably change Long and Short duration power limits in the bios. But my CPU is supposed to run 4.6GHz on all cores as default - i.e. Turbo Boost right?

    My system is running only with XMP enabled - everything else is default/stock on a completely fresh BIOS.

    How come this is happening ?

    My specs:

    i7-9700k
    Asus Rog Strix Z390-F
    NZXT Kraken X72,
    Asus Rog Strix RTX2070
    Corsair Vengeance RGB 3000MHz @ 16GB (2x8)
    Corsair RM750x

    EDIT:

    The only fix I have found was to change short & long duration power limits to 4095 (max).
    I did 10x CBR15 tests and didnt throttle once.

    However, I thought my system would and should be able to run at default settings at 4.6GHz under heavy load without throttling due to power limit.

    Im pretty sure it did so 10 months ago when I got my CPU. So dont know why I had to change settings in BIOS to make this work once again.

    Best regards
    Last edited by joppiano; 04-17-2020 at 05:20 PM.

  2. #2
    Administrator Array Silent Scone@ROG's Avatar
    Join Date
    Mar 2016
    Reputation
    166
    Posts
    2,148

    It sounds like a change in the power rules between UEFI builds. All core boost is dependant on thermal and power conditions, adjusting short and long duration for power limits as you have done is correct.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •