Results 1 to 1 of 1

Hybrid View

  1. #1
    New ROGer Array
    Join Date
    Apr 2020
    Reputation
    10
    Posts
    1

    BIOS issue needing help!

    Hi everyone, I hope you all can help me since ASUS tech support initially led me astray and made my problem worse.

    I have a PC build right now with the following components

    -Meshify C case
    -ROG STRIX z370-e motherboard
    motherboard
    -MSI GTX GeForce 1660 gpu
    -i5-9400f cpu

    Now initially Asus support told me I could flash this mobo prior to my purchase via usb but this is the one model where that can't happen it seems. So I got a friend who let me borrow a i3 8th gen cpu so I could update my BIOS and install my 9th gen CPU.

    The second Asus support rep was very helpful. Confirmed my MOBO BIOS was 0615 so they recommended an update to 1412 or 1803. I downloaded both to a usb and after flashing to one and then the other, neither bios update presented a display after in installed the 9th gen CPU which was supposed to work.

    I got assistance from a friend and we tried seeing if i could get a display under BIOS v 1412 with an hdmi cable into a tv both with and without a GPU installed we also went though and I removed all power and removed/ reapplied my mobo battery to no avail.

    Any thoughts, help, advice you can give? Thanks in advance community!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •