Results 1 to 10 of 1496

Threaded View

  1. #11
    New ROGer Array
    Join Date
    Oct 2018
    Reputation
    10
    Posts
    2

    Update

    Quote Originally Posted by Jesseinsf View Post
    You should be using the following:

    Realtek Audio Drivers (UAD - ASUS ROG SS3 MB) :
    Drivers : 6.0.9191.1 WHQL [22/06/2021]


    Third Party Drivers :

    SS3 Extension Driver : 1.2.14.0 WHQL [02/03/2020]
    SS3 APO SoftwareComponent Driver : 3.3.3.0 WHQL [26/05/2021]



    Download : Link

    ASUS ROG SS3 motherboards :


    Install/Update Process :

    CLEANUP

    /!\ If you already had Realtek (HD) Audio Driver, Realtek Audio Control/Console, Sonic Studio III & Sonic Radar III installed /!\
    Uninstall them (Start > Settings > Apps) then restart your PC
    - Launch Driver Store Explorer > Check the boxes of all versions of drivers which .inf starts with (if you find them) :
    a-volute | avolute | dts | hdx | realtek
    - Check the box "Force Deletion" then click on the "Delete Driver" button then restart your PC

    INSTALL

    - Launch "Install.cmd" by right-click Run as admin > Automatic restart when install is done
    - Automatic installation of Realtek Audio Control/Console after rebooting, if not, install it manually : Link
    - Install Sonic Studio III : Link
    - Install Sonic Radar III (Optional) : Link

    UPDATE

    - Launch "Install.cmd" by right-click Run as admin > Automatic restart when install is done

    Note : Realtek Audio Control/Console + Sonic Studio III & Sonic Radar III will be updated automatically via the MS Store.



    Cool, I had selected the wrong one initially from the main post.

    This is just an update with Install.cmd for me it seems..

    EDIT: Will completely uninstall old stuff I have installed to start from scratch.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •