Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    15

    Gx502gv waking up from deep sleep automatically after sometime

    Apparently I’m being unfortunate with my gx502 but it seems like when I put it in sleep mode (when I suspend it) it’s stays suspended for some time but then it turns on automatically any1 got a fix?

  2. #2
    New ROGer Array Thw0rted's Avatar
    Join Date
    Mar 2020
    Reputation
    10
    Posts
    15

    I don't have a fix, but I did find a blog post yesterday that might provide a step in the right direction. It said to run
    Code:
    powercfg --energy
    from the command line (in Administrator mode) and it will run for one minute, then generate an HTML-formatted report that describes everything that happened in that minute that consumes power. So, you can run it, then put the computer to sleep for at least a minute, then see what it says was running.

    It hasn't been long enough to be sure it helped, but I found it flagged Asus's "Link" executable, which as far as I can tell is the server that their phone app connects to. I don't want to run their phone app anyway, so I went to Windows Services and disabled "ASUS Link Near" and "ASUS Link Remote". Those programs don't run anymore, and in the past 24 hours, I don't *think* it's woken up unexpectedly. If you're not using "Link", it's worth a shot.

    I'm definitely still interested in other advice, though!
    Last edited by Thw0rted; 04-21-2020 at 03:59 PM. Reason: working around broken forum

  3. #3
    New ROGer Array
    Join Date
    Sep 2019
    Reputation
    10
    Posts
    8

    I've had my gx502 for like 8 months and mine just started doing this. It actually has turned on 4 times now in my backpack probably f'ed my laptop all up. I'm done with Asus.

  4. #4
    New ROGer Array Thw0rted's Avatar
    Join Date
    Mar 2020
    Reputation
    10
    Posts
    15

    Has anybody actually sat down with Asus support to see what's going on?

    One thing I've seen other people complain about is that the performance profiles in Armoury Crate take over the Windows power profiles, changing them on certain events without regard for what you've set up yourself. For example, I think it switches profiles every time you plug / unplug the computer. I've tried to customize behavior in Power Options, and sometimes it stays asleep, but sometimes it won't. I have a feeling that it might be due to Armoury Crate tinkering with the settings I fixed.

    I just want to make sure that absolutely nothing can wake it from sleep when it's closed unless I push the power button. That shouldn't be hard!

  5. #5
    New ROGer Array Zlapsa's Avatar
    Join Date
    Apr 2020
    Reputation
    10
    Posts
    6

    Quote Originally Posted by Thw0rted View Post
    Has anybody actually sat down with Asus support to see what's going on?

    One thing I've seen other people complain about is that the performance profiles in Armoury Crate take over the Windows power profiles, changing them on certain events without regard for what you've set up yourself. For example, I think it switches profiles every time you plug / unplug the computer. I've tried to customize behavior in Power Options, and sometimes it stays asleep, but sometimes it won't. I have a feeling that it might be due to Armoury Crate tinkering with the settings I fixed.

    I just want to make sure that absolutely nothing can wake it from sleep when it's closed unless I push the power button. That shouldn't be hard!
    Yeah, it changes configuration definately, but you can disable it putting Armoury crate to "Windows" mode! I am getting same issue as described here - putting laptop to sleep and it wakes up by night few times. Something to do with services waking up or WOL "Magic" packets in your local network - realistically - there is bunch of cases why it wakes up, even your installed software.

  6. #6
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    9

    I have a problem similar to this in my GX531 put mine I guess something wakes up from a complete shut down working in background or something which cause the laptop to drain power sometimes when it shut down .

    Try to write in CMD this command to see what's making your laptop wake up : powercfg devicequery wake_armed

    & disable the devices that make your laptop wakes up from device manager ,test it again & see if something changed or not

    in my problem I disabled every thing but windows enables " nvidia usb type-c port policy controller" every time & I don't know why & I don't know if this the driver that it causes this problem to me or not
    "
    Last edited by neweshy; 05-08-2020 at 10:32 PM.

  7. #7
    New ROGer Array Thw0rted's Avatar
    Join Date
    Mar 2020
    Reputation
    10
    Posts
    15

    That's really interesting about the "NVidia USB-C port" device. I do have a device with that name, under USB Controllers. You say it gets re-enabled when you disable it? Might be worth taking it up on NVidia's forums. I did find one post about it but it didn't really go anywhere.

    For reference, when I run the command you gave, it lists that NVidia device and two HID keyboards. (For some reason, I show 2 USB and one PS/2 keyboard even though I don't have any extra keyboards hooked up -- maybe the "extra" keys present as separate devices?)

    Intuitively, it seems like the keyboard shouldn't be issuing random wakes, and the driver is Microsoft-provided, dated 2006 (!) so if it was, you'd think someone would have noticed by now and fixed it. That means the only *device* that's likely to be causing wake events is the NVidia controller you found. (I say "device" because I guess it could also be a service?) Anyway, I went ahead and opened the device properties in the Device Manager, and unchecked "Allow this device to wake the computer" in the Power Management tab. We'll see if that makes any difference.

  8. #8
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    9

    yes, Every time I uncheck" allow this device to wake the computer " I found windows re-enabled it again after restart or full shutdown " without fast boot " , actually it's very weird & I don't know the real cause !

    you are right maybe it's a service, you know when I tried to disable it completely from device manager " disable device" the GPU started to heat and laptop started to consume a lot of power as if the GPU is working but it's not !!!

    Actually till now I am not sure if this is the real problem or not , please if you found any thing might help tell me .

  9. #9
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    15

    Quote Originally Posted by neweshy View Post
    yes, Every time I uncheck" allow this device to wake the computer " I found windows re-enabled it again after restart or full shutdown " without fast boot " , actually it's very weird & I don't know the real cause !

    you are right maybe it's a service, you know when I tried to disable it completely from device manager " disable device" the GPU started to heat and laptop started to consume a lot of power as if the GPU is working but it's not !!!

    Actually till now I am not sure if this is the real problem or not , please if you found any thing might help tell me .
    you can try to uninstall the driver to see if it helps I actually uninstalled it some time ago for this reason it isn’t anything too important and you can just redownload it through nvidia site if you want it back*

  10. #10
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    9

    try also to disable " sleep wake timer" in windows you will find it in -> power options -> change plan settings -> change advanced power settings -> sleep -> allow wake timer -> disable

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •