Results 1 to 2 of 2

Threaded View

  1. #1
    New ROGer Array
    Join Date
    Sep 2019

    ROG G531GT Keyboard Framework Version 2.2.3 not Downloading

    Ever since I tried to update my keyboard framework to 2.1.8 and my keyboard stopped working completely. I didn't want to get it to a service centre as I had too much work to do and couldn't afford to be without a laptop for more than a week. I hoped that they will publish a new update and fix this issue!

    A couple of weeks ago a new version came out 2.2.3 but it is still not working. II checked the logs that the installation is producing and got this

    Tool Version : 2.2.3
    Product Name : G531GT
    [Initialize] Start Flash : 20200421000503
    [Initialize] GetKBType : 0
    [Initialize] UnReg LightingService
    [Initialize] Battery Power Level : 100
    [Initialize] GetASUSDevice fail
    [Initialize] GetITEDevice

    So somehow it is stopping at this stage GetASUSDevice

    Any advice on how to solve this? I am pretty stressed to carry a wireless keyboard everywhere I go...

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts