Results 1 to 9 of 9
  1. #1
    ROG Member Array
    Join Date
    Jan 2015
    Reputation
    10
    Posts
    7

    Lagging when gaming via wifi - g751jt

    Hi guys,

    I just recently bought a g751jt and loves it. However, i havet noticed that when playing cs go the game will lagg just suddenly every time. I am using wifi 5ghz and i am about 1 feet away from the router. My downloading speed is excellent and various internet speed tests shows great results. I have tried to install the newest wifi drivers from Intel but the problem still exist.

    My other laptop does not show any sign at all of lagg when playing.

    Anyone know what the problem could be?

    Many thanks in advance.

  2. #2
    ROG Guru: White Belt Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    105

    Is asus gaming center...it slows the speed ....dezinstall and try again...tell me if it works,mine worked great after

  3. #3
    New ROGer Array
    Join Date
    Dec 2014
    Reputation
    10
    Posts
    1

    I have the same problem, I play guildwars2 all the time.. every other minute i will have a about 3 seconds lag spike, really need to fix it , so annoying.

  4. #4
    ROG Guru: White Belt Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    105

    i told u the fix

  5. #5
    New ROGer Array
    Join Date
    Feb 2015
    Reputation
    10
    Posts
    1

    I tried uninstalling Gaming Centre and i sill get the occational lag. :-(

  6. #6
    New ROGer Array
    Join Date
    Mar 2015
    Reputation
    10
    Posts
    4

    Quote Originally Posted by Henko View Post
    I tried uninstalling Gaming Centre and i sill get the occational lag. :-(
    Hi,

    I just bought mine 2 days ago. I have the samme issue with occasional lag in League of Legens playing via Wifi.
    I also tried deinstalling Gaming Center III but it didn not help.
    Would apreciate any suggestions.

  7. #7
    ROG Enthusiast Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    65

    this solved it for me: "http://jakthebomb.tumblr.com/post/90717903679/intel-wireless-ping-spikes-and-lag-fixed"

  8. #8
    New ROGer Array
    Join Date
    Mar 2015
    Reputation
    10
    Posts
    4

    thank you SO much Evil Hotdog.
    I just did a quick test and it seemed to run. I loved the machine so far but this was not acceptable. Its seems to be gone now
    Tanks again!

  9. #9
    New ROGer Array
    Join Date
    Apr 2020
    Reputation
    10
    Posts
    2

    random high ping solution

    Hello, i had this random lag spike issue too. no matter what i did ( suggestions over the internet ) it didnt resolve, but i managed to fix it in the end. here is what i did;

    in the wireless adapter options > configuration ( properties ) > advanced tab , " wireless mode " was on " auto ". i changed it to " IEEE 802.11a/n/ac " and after that i never had any spikes or anything. also my speed was increased too...

    i hope this helps you. <3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •