Results 1 to 3 of 3
  1. #1
    ROG Junior Member Array
    Join Date
    Sep 2015
    Reputation
    10
    Posts
    2

    Angry Unable to RMA/Unable to contact support. Help?

    Hello,

    I've been trying to submit an RMA online for my CH7 (Wifi) motheboard with absolutely 0 success. I used the self-help tool and like others in this forum have experienced, I get the message below:

    Code:
    Thank you for using the ASUS Online RMA feature.It looks like your serial number(SN:undefined)has already been issued an RMA.
    For your reference,the RMA number is undefined.You should have received the RMA instructions in a separate e-mail.Please allow up to 48
    hours for it to be sent out.
    It's been more than 48 hours and I haven't received a follow up message. In addition, I've tried to chat and get the message that chat isn't available. Then I tried to call the support line for it to say there is no support for components at this point. I understand this is special times but is there no hope for me?

    Best,

  2. #2
    ROG Guru: Yellow Belt Array
    Join Date
    Jul 2016
    Reputation
    10
    Posts
    186

    Hi Maleymaley,

    Sorry to hear about the issues you're having with creating an RMA. You will get this message when there's already an active RMA. I can gladly help you investigate your case, please email me at cl-justin@asus.com with the following information:

    Serial number:
    Full Name:
    Email:
    Contact #:
    Shipping Address

  3. #3
    ROG Junior Member Array
    Join Date
    Sep 2015
    Reputation
    10
    Posts
    2

    Thanks Justin. Will do!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •