Results 1 to 1 of 1
  1. #1
    New ROGer Array Lord Sinclair PC Specs
    Lord Sinclair PC Specs
    MotherboardASRock Z370 Taichi
    ProcessorIntel Coffee Lake, Core i7 8700K 3.70GHz
    Memory (part number)Corsair Vengeance LPX Black 32GB DDR4 2400MHz CL14 Dual Channel Kit
    Graphics Card #1GIGABYTE GeForce GTX 1080 Ti GAMING OC 11GB DDR5X 352-bit
    MonitorASUS ROG Swift PG348Q Curved 34inch 5ms G-Sync 100Hz
    Storage #1SSD 2TB
    Storage #2HDD 2.5TB
    CPU CoolerWater Cooler
    CaseCorsair Carbide SPEC-02 Red LED
    Power SupplySirtec - High Power Super GD, 80+ GOLD, 1600W
    Keyboard ASUS ROG GK2000 Horus Cherry MX Red RGB Mechanical Keyboard
    Mouse ASUS ROG Gladius II Origin
    Headset ASUS ROG Delta RGB
    Mouse Pad ASUS ROG GM50 Plus
    Headset/Speakers ASUS ROG Delta RGB
    OS Windows 10-64 bit
    Network RouterInternet Provider Router - DIGI Romania
    Accessory #1 ROG Throne Qi
    Lord Sinclair's Avatar
    Join Date
    Apr 2020

    Exclamation EMERGENCY HELP | Armoury Crate BUGGED

    ADMINISTRATOR/MODERATOR please read this and try to help me!

    Hello there fellow gamers, I've ran into a WHOLE LOT of problems with the armoury crate "thing". I can't call it "driver/software" because it's pure garbage.

    I got all peripherals from ROG (monitor,mousepad,mouse,keyboard,headphones and ROG throne qi). I do not own a ROG motherboard.

    The armoury crate does NOT detect any devices, and only shows "MACRO" when I click on the devices button. I tried replugging them, reinstalling it, and tried searching for error fixes. No answers at all. If any of you work at ASUS, please do not hesitate to e-mail me with a step-by-step guide on how to fix the app.

    I just want to configure my ROG Delta headphones that just arrived today, and as far as I can see, I can't seem to change their audio settings because the armoury crate is broken.

    Also, I got ONE MORE problem, because why not. Whenever I try to open the "ROG Armoury" app (the classic one), it tells me to unsynchronize the devices (peripherals) from Aura sync, even if I do not use aura sync at all. Aura creator is not on my system. Please help, all of those softwares are bugged and I can not configure any of my ROG Peripherals.


    I contacted ASUS Support through e-mail and Freya contacted me and told me to install some software in a right order. I did that, and it is still the same. If any of you could help me to remove ALL ASUS software (drivers, tools, etc) so I can install the software again in a right order?
    Last edited by Lord Sinclair; 04-23-2020 at 01:22 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts