Results 1 to 1 of 1
  1. #1
    ROG Junior Member Array
    Join Date
    Mar 2013
    Reputation
    10
    Posts
    1

    Need a lil clarification with my board rog strix z390 e and 9900k

    So i have a 9900k and the rog strix z390 e.... put in the chip popped in a ram stick that i know works and works on another system plugged in power supply and dropped in my evo m2 drive plugged in mouse keyboard and did onboard hdmi powered on and cpu fan spins(used a stock air cooler fan to test board did not hook up a aio tho i could) board turns on but get no lights for ram cpu etc near power plug to go on. I get a black screen only can't get into bios dont get no splash screen. So tried with a gtx 770 attached same thing nothing... then cleared cmos correctly moved ram to each slot, even added second stick, reaseated cpu, used another working power supply first was a 850 this one is a 1350 I have laying around that works and still get no indication lights from the lights near the power supply plug. board lights up otherwise (led) and fan spins on cpu fans and on gpu but nothing else. Question the board says it came with 0903 bios on the sticker on mobo does this bios need to be updated to allow the 9900k to work? i seen on the asus support of cpu for this board it says Core I9-9900K (3.6GHz, 95W, L3:16M, 8C, rev.R0) ALL 1005 .....under the cpu list. But then I have heard that people have said that 9900k should work with a 390 board straight up.. Idk what to do? how do i even update the bios without a 8th gen cpu or is my board just doa and has a issue.. please someone help i have built all my pc's for years boards been rog rampage series and i'm used to those this is my first non rampage series and wanna get this working.. some help would be welcome. ty

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •