Results 1 to 7 of 7
  1. #1
    ROG Guru: White Belt Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    79

    G750JS weird restarts when pressed buttons on the keyboard...

    ...just recently i had like 4-5 restart because of "T" "Y" and "G". Every time I pressed those buttons the laptop restarted.
    After complete shutdown and wait for 1 min it is back to normal (for now). I have the machine from a year and never had this problem.
    Last edited by matau; 04-21-2020 at 09:55 AM.

  2. #2
    ROG Guru: White Belt Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    79

    Can someone help out, please? Today I got a few restarts again when I press these buttons.

  3. #3
    ROG Enthusiast Array
    Join Date
    Nov 2019
    Reputation
    10
    Posts
    45

    Quote Originally Posted by matau View Post
    Can someone help out, please? Today I got a few restarts again when I press these buttons.
    it's a physical problem, you need to open your laptop and shield few places with electric tape so they don't shortcircuit. stop using your laptop before this fix or you can damage the motherboard permanently.
    Search this forum for answer, there are many threads regarding this subject.

  4. #4
    ROG Guru: White Belt Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    79

    I searched but I didn't find anything related with this. Is there a guide how to open it?

  5. #5
    ROG Member Array
    Join Date
    Mar 2018
    Reputation
    10
    Posts
    17

    Had the same issue with my laptop when i bought it a year ago . Pressing certain buttons laptop would just instantly power off , like a short circuit would occur. In my case the problem was the Nvidia driver - uninstalled everything and installed new driver without the nvidia audio driver etc , only the gpu driver. Never had issues since then. Hope it helps.

  6. #6
    ROG Guru: White Belt Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    79

    Thanks for the info!
    The only thing I did when this problem start occur was to install sonic studio software.
    When i uninstalled it, it seems the problem is gone.

    @Passion64x How did you know the problem is Nvidia audio driver?
    Last edited by matau; 04-21-2020 at 09:57 AM.

  7. #7
    ROG Member Array
    Join Date
    Mar 2018
    Reputation
    10
    Posts
    17

    I traced the keys that would kill the pc to nvidia global keys. Then started from there by uninstalling everything nvidia related. Reinstalled and problem persisted. Reinstalled again , but without experience and audio driver and it fixed it . Good to hear you fixed the issue as well .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •