Results 1 to 8 of 8
  1. #1
    ROG Member Array
    Join Date
    Jul 2013
    Reputation
    10
    Posts
    15

    G750 jw keyboard backlight

    Hi all , I have a g750jw bios 210 i cant get the keyboard back light to work . I have replaced the keyboard. reinstalled the atx package looked on the internet . cant find a solution . I do get the error in the device manager event log under keyboard.

    Device ACPI\ATK3001\4&25eef08&0 was not migrated due to partial or ambiguous match.

    Last Device Instance Id: HID\VID_046D&PID_C07C&MI_01&Col01\7&15d58638&0&000 0
    Class Guid: {4d36e96b-e325-11ce-bfc1-08002be10318}
    Location Path:
    Migration Rank: 0xF000FFFFFFFFF100
    Present: false
    Status: 0xC0000719

    I have no idea how to fix this . And i am assuming since the keyboard works fine the above has something to do with the backlight.

    everything else on the function keys works fine just no keyboard lights .

  2. #2
    ROG Guru: Blue Belt Array
    Join Date
    Nov 2012
    Reputation
    75
    Posts
    765

    Have you tried to uninstall the offending device in device manager then reboot laptop?

    Here's a link to the latest ASUS ATK driver:

    https://dlcdnets.asus.com/pub/ASUS/n...ge_V100061.zip
    Last edited by jdfrench3; 04-26-2020 at 11:00 PM. Reason: Added info
    G752VSK, G75VW-3D, G51J, G1S
    Homebuilt Windows Server

  3. #3
    ROG Member Array
    Join Date
    Jul 2013
    Reputation
    10
    Posts
    15

    yes , that would be the keyboard . i did and it came back the same. I have those drivers already

  4. #4
    ROG Guru: Blue Belt Array
    Join Date
    Nov 2012
    Reputation
    75
    Posts
    765

    Have you manually tried to install the original ATK driver from your eSupport folder?

    This would only apply if your laptop came with Windows 10.

    There is a conflict with older (Windows 7 & 8) ATK drivers and Windows 10 ATK drivers.

    When upgrading from Windows 7 or 8, then the newer ATK driver must be installed.

    There is also a keyboard hotkeys driver:

    https://dlcdnets.asus.com/pub/ASUS/G...0_64_V2080.zip
    Last edited by jdfrench3; 04-27-2020 at 06:24 AM. Reason: Added info
    G752VSK, G75VW-3D, G51J, G1S
    Homebuilt Windows Server

  5. #5
    ROG Member Array
    Join Date
    Jul 2013
    Reputation
    10
    Posts
    15

    It came with windows 8 . But i upgraded it to windows 10 a long time ago . The light always worked prior top my having to replace the MB . It was orginally a JX this MB is a JW. Everything works fine the laptop works fine other than the keyboard back light. I even went has far has buying a new keyboards thinking when i may have damaged the orginal one .

    I tried all the files you posted , I have tried everything i could find out on the internet. nothing seems to work.

  6. #6
    Super Moderator Array
    Join Date
    Jan 2013
    Reputation
    100
    Posts
    2,242

    Quote Originally Posted by tjwhite View Post
    It came with windows 8 . But i upgraded it to windows 10 a long time ago . The light always worked prior top my having to replace the MB . It was orginally a JX this MB is a JW. Everything works fine the laptop works fine other than the keyboard back light. I even went has far has buying a new keyboards thinking when i may have damaged the orginal one .

    I tried all the files you posted , I have tried everything i could find out on the internet. nothing seems to work.
    If everything was fine until you replaced the motherboard, ASUS repair normally needs to enable the keyboard backlight function at their facility when they replace motherboards (no idea why this function isn't already enabled with replacement motherboards, but it appears to be this way), so if ASUS repair replaced the motherboard for you, you may want to send it back to them to fix this.

    If you replaced the motherboard yourself, not sure if you can still find that utility or that I'm supposed to even be talking about it (if something goes wrong, things can get worse), but it was discussed on the ROG forums at one time for older notebooks.

    Found one older thread below if you want to check it and there may be others, but doesn't look like the download link is working anymore unfortunately.

    https://rog.asus.com/forum/showthread.php?39519-My-laptop-s-backlight-is-not-working-solved/page2

  7. #7
    ROG Member Array
    Join Date
    Jul 2013
    Reputation
    10
    Posts
    15

    Quote Originally Posted by cl-Albert View Post
    If everything was fine until you replaced the motherboard, ASUS repair normally needs to enable the keyboard backlight function at their facility when they replace motherboards (no idea why this function isn't already enabled with replacement motherboards, but it appears to be this way), so if ASUS repair replaced the motherboard for you, you may want to send it back to them to fix this.

    If you replaced the motherboard yourself, not sure if you can still find that utility or that I'm supposed to even be talking about it (if something goes wrong, things can get worse), but it was discussed on the ROG forums at one time for older notebooks.

    Found one older thread below if you want to check it and there may be others, but doesn't look like the download link is working anymore unfortunately.

    https://rog.asus.com/forum/showthread.php?39519-My-laptop-s-backlight-is-not-working-solved/page2
    Ya , IDK . I found that BT.exe thing and i have tried that also . that didnt work either . Maybe a fresh windows install will do it. When i replaced the MB i never did that . the laptop booted up and operated fine . I just cant solve this key backlight issue
    Last edited by tjwhite; 04-29-2020 at 10:07 PM.

  8. #8
    ROG Member Array
    Join Date
    Jul 2013
    Reputation
    10
    Posts
    15

    FIXED: found this thread https://rog.asus.com/forum/showthrea...-backlight-fix
    IT SHOULD BE STICKY IT WORKS
    I have been chasing this for 3-4 months.
    Senerio
    My g750jx MB died. I bought a used same serial number board but it was flashed has a JW model. I was trying to find out how to flash the board to a jx to no avail. My other theroy was i needed a fresh install of win 10 . I didnt have to do that when i installed the new board. Everything worked fine except the keyboard lights. I did the fresh install checked my device manager and saw my device not migrated error gone . I found the above thread did it and finally keyboard lights .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •