Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Apr 2020
    Reputation
    10
    Posts
    2

    Asus G20AJ CPU UPGRADE

    Hi Guys

    I got a question about my Asus g20AJ , i had i5 4460 with gtx960.Yesterday i sold my both gpu and cpu and bought i7 4790 today but the think is that i didnt realized that the cpu is i7490S version, so i put the cpu and igot nothing at all , when i press the power button fans spins for a second and stops.So I cant determine that if the cpu is faulty or its not compatible due to it is S version.I only have the 230 power brick but currently no gpu so i dont think power brick is the issue .Any ideas ?

  2. #2
    ROG Guru: Yellow Belt Array Welsh Whoopee's Avatar
    Join Date
    Jan 2016
    Reputation
    18
    Posts
    243

    welcome to the forums, so no GPU is plugged in, did you use the hdmi port on the back to check the screen? does it get to the bios? the only thing I can think of is a bent pin, did you put the new cpu in place nice and gentle? I would strip her back down and take the coolier back off and the CPU, check the socket and see if any bent pens, if none then put back on with some fresh thermal paste and coolier on and power up and see what happens. check the power brick also if you have 2, check the watts on back, its the biggest socket to plug in if I remeber.

    thanks Whoopee
    YOUTUBE CHANNEL @ http://bit.ly/2LNo1dI

    ASUS ROG G20 PLAYLIST @ http://bit.ly/2R9njXC

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •