Results 1 to 2 of 2
  1. #1
    ROG Member Array
    Join Date
    Feb 2018
    Reputation
    10
    Posts
    5

    ASUS GL503V can't get past bios screen

    hello. it appears that the SSD died in a ASUS GL503V. it just doesn't get past the ez bios screen. i took it out and it doesn't show up on any PC. it also doesn't show up at all in the BIOS of the ASUS GL503V. i tried swapping in a NVMe, but apparently it doesn't work with it? i thought it took those too, but it doesn't show up either. could this be more than a bad booting SSD? thanks!

  2. #2
    Super Moderator Array
    Join Date
    Jan 2013
    Reputation
    100
    Posts
    2,242

    Hi,

    Not sure which GL503V model you have, but according to the global website specs below, looks like it should be supporting NVMe drives.

    https://www.asus.com/ROG-Republic-Of-Gamers/ROG-Strix-GL503/Tech-Specs/

    You will not normally see NVME drives listed in the bios with the SATA devices though, so if you can't find another section for IRST or NVMe drives, it may be possible your bios just doesn't list them separately.

    If you have a Windows installation drive around and haven't tried booting to it yet, you may want to check if you can still partition and install Windows to your NVME drive despite what the bios shows?

    If Linux was installed on the NVME drive, you may need to find a way to format it so that the Windows installation disk can recognize it though.

    Otherwise, if you have a repair shop that you trust, you may want to consider asking them to look into it more.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •