Results 1 to 4 of 4
  1. #1
    New ROGer Array
    Join Date
    Apr 2020
    Reputation
    10
    Posts
    3

    Gu502gw Poor internet download speeds after fresh installing Windows 10.

    I have Asus rog Zephyrus gu502gw. I had to fresh install Windows. After that all Asus preinstalled content got removed (not that I wanted them anyway). My internet download speed got very poor, but upload speed is fine. I tried tweaking wifi router settings (changing channels etc) but without any luck. I also updated Intel wireless driver to the lastest version. I 100% know that it's not a hardware issue, I checked the packet loss and etc. How could I fix this? Answers would be much appreciated!

  2. #2
    New ROGer Array Jesseinsf PC Specs
    Jesseinsf PC Specs
    MotherboardASUS ROG Maximus XI Extreme (Z390)
    ProcessorIntel Core i9 9900K
    Memory (part number)Corsair CMW128GX4M4E3200C16
    Graphics Card #1NVIDIA - GeForce RTX 2080 Ti FE
    Sound CardCreative Labs Sound Blaster AE-9
    MonitorSamsung 32" UH750 QLED UHD Monitor
    Storage #1Samsung 970 Pro M.2 PCIe SSD 1TB
    CPU CoolerCooler Master MLX-D36M-A20PC-R1 w/ Noctua NF-F12 industrialPPC-2000 IP67 PWM x3 Fans
    CaseLian Li PC-011 Dynamic XL (ROG Certified)
    Power SupplyCooler Master V1200 Platinum
    Keyboard RAZER HUNTSMAN ELITE - LINEAR OPTICAL SWITCH (Red) w/ PBT Keycaps
    Mouse Razer Basilisk Ultimate with Charging Dock
    Headset Bowers and Wilkins P9 Signature
    Mouse Pad Razer Vespula V2 Mousepad
    Headset/Speakers Creative GigaWorks T40 Series II
    OS Windows 10 Pro for Workstations
    Network RouterROG Rapture GT-AC5300
    Accessory #1 Microsoft Xbox Elite Wireless Controller Series 2
    Accessory #2 Logitech BRIO ULTRA HD PRO WEBCAM
    Jesseinsf's Avatar
    Join Date
    Mar 2019
    Reputation
    22
    Posts
    218

    How and what did you use to install a fresh copy of Windows? Did you install Armoury Crate?

  3. #3
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    14

    Quote Originally Posted by Leon_idas View Post
    I have Asus rog Zephyrus gu502gw. I had to fresh install Windows. After that all Asus preinstalled content got removed (not that I wanted them anyway). My internet download speed got very poor, but upload speed is fine. I tried tweaking wifi router settings (changing channels etc) but without any luck. I also updated Intel wireless driver to the lastest version. I 100% know that it's not a hardware issue, I checked the packet loss and etc. How could I fix this? Answers would be much appreciated!

    I had the same problem, not that I had a poor download speed but I had 200 vs 500 from my iPad which made me a bit upset all you’re missing is the multi antenna driver look for it in the driver page once I installed it voila 500 In download speed*

  4. #4
    Moderator Array
    Join Date
    Feb 2019
    Reputation
    13
    Posts
    439

    Hello Leon_idas,
    Please refer to below link of our official support website.
    Make sure all the drivers you need are installed
    https://www.asus.com/Laptops/ROG-Zep...Desk_Download/
    Thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •