Results 1 to 2 of 2
  1. #1
    New ROGer Array Synergist PC Specs
    Synergist PC Specs
    MotherboardAsus ROG Maximus Hero XI
    ProcessorIntel i9-9900K @ 4.9 GHz
    Memory (part number)Corsair Vengeance 32GB 3000MHz (CMK32GX4M2D3000C16)
    Graphics Card #1EVGA GeForce GTX1070 SC ACX3.0
    Sound CardVarious
    MonitorViewSonic XG2703-GS
    Storage #1Intel 750 Series NVMe PCIe 400GB
    Storage #2WD Black 4TB & WD Blue 1TB
    CPU CoolerCorsair H100i Platinum RGB
    CaseCorsair Carbide 400C
    Power SupplyCorsair RM750x
    Keyboard Coolermaster MasterKeys Pro S RGB
    Mouse DeathAdder Elite
    Headset Sennheiser HD25 and HD650
    Mouse Pad Steelseries QCK+
    Headset/Speakers Various
    OS Windows 10 Pro 64-bit
    Network RouterVarious (ProSafe wired, Asus RT-AC66U_B1 as WiFi extender)
    Synergist's Avatar
    Join Date
    Mar 2020

    Product registration not working?

    I've just tried to register my recent purchase - entering the serial number onto, the page correctly detects the motherboard model, however when I submit the form it says "serial number incorrect!".

    using the other registration form at , when I submit the form it just shows "*register return null" in red under the sign-in form.

    I've tried a few times, triple-checked the serial as printed on the box sticker and retyped to avoid any human error. What's up? Is this a known fault with the site?

    The ROG Elite registration form also seems broken (I had chosen the PDF of my invoice before submitting):

    And incidentally, forum-based image upload also seems broken. It can't retrieve an image and auto-reference locally, nor can I upload a PNG direct using the upload form.
    Last edited by Synergist; 04-19-2020 at 02:07 AM.

  2. #2
    New ROGer Array
    Join Date
    Apr 2020

    Same Issue

    Following, same issue

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts