Results 1 to 3 of 3
  1. #1
    ROG Junior Member Array
    Join Date
    Dec 2017

    Maximus X Hero Ethernet dropping connection

    Hi guys, in the past couple of months, my on-board ethernet has been dropping the connection to my switch/router, which I've verified by pinging, as well as observing that the ethernet light on my switch port turns off during periods of downtime. I've even gone as far as to purchase a new switch to verify that it is my PC's problem and not the switch's.

    I've tried installing the latest official drivers from the ASUS website, as well as Mokichu's provided drivers for the ethernet adapter but it isn't helping. I saw that a previous post asked the OP to clear CMOS and restore settings, and I did try that, which helped for maybe a day before the problem started again. Is my ethernet adapter crapping out?

    I've already placed an order in the meantime for a USB Ethernet adapter but that's not an ideal solution. Really hope someone can help me out.

  2. #2
    ROG Junior Member Array
    Join Date
    Dec 2017

    I've now tried resetting my CMOS again, as well as removing my overclock and I'm still getting the problem. Would sincerely appreciate any advice.

  3. #3
    ROG Member Array Devoid PC Specs
    Devoid PC Specs
    MotherboardASUS Maximus XI Hero
    Memory (part number)HX440C19PB3/8
    Graphics Card #1MSI Ventus RTX 2080 Ti
    Graphics Card #2Zotac RTX 2080 Ti Twin Fan
    Graphics Card #3N/A
    Graphics Card #4N/A
    Sound CardSennheiser HDV 820
    MonitorSamsung CRG9
    Storage #1Samsung 970 Pro 1TB
    Storage #2Samsung 970 Pro 1TB
    CPU CoolerCorsair H150i Pro
    CaseCorsair 500D RGB SE
    Power SupplySilverstone Strider Platinum 1200W
    Keyboard Steelseries Apex Pro
    Mouse Razer Viper Ultimate
    Headset Sennheiser HD800S
    Mouse Pad Logitech G640
    Headset/Speakers N/A
    OS Windows 10 Pro x64 OEM
    Network RouterASUS DSL-AC88U
    Accessory #1 Samson Go Mic USB Condenser Microphone

    Join Date
    Sep 2013

    This is going to sound weird but is your ram overclocked / in XMP?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts