Results 1 to 2 of 2
  1. #1
    New ROGer Array pointofdeparture PC Specs
    pointofdeparture PC Specs
    MotherboardASUS Prime-X570 Pro
    ProcessorAMD Ryzen 3600
    Memory (part number)G. Skill F4-3600C16D-32GVKC
    Graphics Card #1EVGA GeForce GTX 970 4 GB SSC ACX 2.0+
    MonitorASUS VE248H
    Storage #1Samsung 850 EVO
    CPU CoolerScythe Mugen 5 Rev. B
    CasePhanteks Enthoo Pro M SE
    Power SupplyRosewill Photon 650
    pointofdeparture's Avatar
    Join Date
    Nov 2019

    X570 rear USB-C only charges (Data transfer does not work)?

    So I have a Prime X570-Pro board and recently purchased a new iPhone that uses USB 3.2 Gen 2 (aka Type-C) for fast charging & data. I hooked it up to my PC and while the phone charges, data transfer does not work.

    Thinking it may be a cable problem I tried the same setup on my Dell laptop and everything worked fine.

    Has anyone else experienced this issue on an ASUS X570 board? How did you get the rear USB-C working correctly?

  2. #2
    ROG Member Array adrian_arg PC Specs
    adrian_arg PC Specs
    MotherboardASUS x570 TUF Gaming Wi-FI
    ProcessorAMD Ryzen 7 3800x
    Memory (part number)PVS416G320C6K
    Graphics Card #1ASUS RX570 Rog Strix 8GB
    Sound CardAudient ID14
    MonitorSamsung 23"
    Storage #1XPG Gammix S50 1TB
    Storage #2Western Digital Black 2TB+1TB+1TB
    CPU CoolerStock Wraith RGB + AeroCool
    CaseAeroCool Aero-800
    Power SupplySentey 750W
    Keyboard A4Tech
    Mouse Logitech MX518
    Mouse Pad HyperX
    Headset/Speakers Edifier R1900 TII
    OS Windows 10 2004
    adrian_arg's Avatar
    Join Date
    Jul 2020


    Is it fast-charging or normal?
    I have an X570 TUF Gaming and an Android Phone with quick-charge.
    Researching in forums someone mentioned that they pushed the connector against the port and held it and it worked.
    My cable disconnects fairly easily, so I tried connecting the cable that came with my phone and it stays connected, unfortunately I cannot use it for charging the phone itself and test as it is a Type-C to Type-A cable.
    Apparently there's an issue with the USB Type-C cable I purchased.
    If i don't hard-press it against the port, I get regular charging speeds and the device is not detected as a storage device.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts