Results 1 to 1 of 1
  1. #1
    New ROGer Array pointofdeparture PC Specs
    pointofdeparture PC Specs
    MotherboardASUS Prime-X570 Pro
    ProcessorAMD Ryzen 3600
    Memory (part number)G. Skill F4-3600C16D-32GVKC
    Graphics Card #1EVGA GeForce GTX 970 4 GB SSC ACX 2.0+
    MonitorASUS VE248H
    Storage #1Samsung 850 EVO
    CPU CoolerScythe Mugen 5 Rev. B
    CasePhanteks Enthoo Pro M SE
    Power SupplyRosewill Photon 650
    pointofdeparture's Avatar
    Join Date
    Nov 2019
    Reputation
    10
    Posts
    2

    X570 rear USB-C only charges (Data transfer does not work)?

    So I have a Prime X570-Pro board and recently purchased a new iPhone that uses USB 3.2 Gen 2 (aka Type-C) for fast charging & data. I hooked it up to my PC and while the phone charges, data transfer does not work.

    Thinking it may be a cable problem I tried the same setup on my Dell laptop and everything worked fine.

    Has anyone else experienced this issue on an ASUS X570 board? How did you get the rear USB-C working correctly?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •